Printer Name is Invalid

  mpearo 20:46 08 Sep 2007
Locked

Hi,

Having a problem installing a printer (Lexmark P4350)

When I attach the printer I am getting two error messages

1.High speed usb device plugged into a non high speed usb hub. - Says I need to install a high speed hub to get full speed

2. There was a problem installing this hardware. The Printer name is invalid. - Tried installing manually but get the same problem.

When installing from the disk it appears to complete the install but the PC does not register that a printer is attached in the printers and faxes section of control panel.

Are the two messages related ? - any ideas >

Thanks

  €dstowe 21:18 08 Sep 2007

Are you connecting the printer before installing the software?

I don't know about that particular model but most printers require the software to be installed first.

  mpearo 21:37 08 Sep 2007

I've tried installing software first, then attaching printer and visa versa but no luck

  [email protected] 21:43 08 Sep 2007

mpearo,
didnt you have a usb related problem last week?
cant check postings but could it be related?

  mpearo 22:04 08 Sep 2007

hi raven,

usb problem was with a different machine. - was a capacitor issue on that one.

  €dstowe 22:12 08 Sep 2007

Try this:

Open Printers and Faxes from the Start menu or control panel. If there are ANY instances of this printer in the listing that comes up, highlight it and click on Delete (or right click and delete).

Also go to Add remove programs in Control panel and check there are no instances of anything to do with the printer there. If there are, delete them as well.

That done, try installing the software EXACTLY according to the instructions. Don't deviate at all.

  [email protected] 22:17 08 Sep 2007

ok,
not having much luck are you,

hopefully €dstowe solution works,as m just guessing:-)

check in device manager,usb section for enhanced usb controller or high speed controller,to see if it has usb 2.0 enabled.

also try it in one of the rear usb ports if not already

not sure how much the two errors are related but guessing if its not being picked up correctly,
"need to install a high speed hub to get full speed"
is consequently not installing properly

  woodchip 22:24 08 Sep 2007

Are you trying to connect to a VISTA computer by any chance? If so throw the Lexmark away. Get a Epson or Cannon printer. Lexmark Drivers are no good for VISTA

  mpearo 22:36 08 Sep 2007

Woodchip = not Vista, installing to XP

Raven, doesn't look like it's got an enhanced usb controller, tried the rear ports as well.

The ports installed are intel(r)82801BA/Universal USB Host Controller - 2442

and -2444

can high speed controllers be downloaded ?

  [email protected] 23:01 08 Sep 2007

how old is the pc?

check the bios for enhanced usb and check if its enabled.

check if its got usb 2.0 card installed
click here

you cant download a controller you need the hardware to have usb 2.0 speed
click here
also check the printer installation guide /leaflet see if its backward compatible with usb 1,if it is the above is irrelevant

  mpearo 23:11 08 Sep 2007

PC is 5 years old checked the bios and there is no enhanced usb listed.

printer is an all in one printer, scanner, fax.

sounds like i may need to install a usb 2 card to make this work ?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 Hack Latest News: How Secure is your Wi-Fi?

Photoshop CC 2018 released with new Curvature Pen and better brush tools

Best kids apps for iPhone & iPad

Comment utiliser Twitter ?