Printer installation in XP Pro vanished!

  Geldon 03:27 27 Jun 2003
Locked

Can anyone help with this weird prob? I'm running XP Pro and until this problem, had an Epson Stylus Colour 760 printer installed OK. Recently, I downloaded a 30 day trial of Iolo's System Mechanic to check it out. Before installing it, made a manual System Restore point so could roll back if there were any probs. Ran System Mechanic and there werent any immediate probs but it wasnt until a few days later when I went to use the printer that I noticed the installation had vanished! The folder for the installation was still there but there were no printers listed in the Printers and Faxes part of Control Panel. I plugged in the USB printer cable and got the 'bong-bing' connection sound but nothing else - no 'Found new hardware' wizard or anything. Went to Control Panel, Printers and Faxes, clicked on Add a printer and that is where I got the following error message: 'Operation could not be completed'. No probs I thought, I'll roll back XP to before the installation of System Mechanic. Did that, plugged in the printer again, 'bong-bing' but nothing again and still no 'New hardware found' wizard. Tried a manual installation, got the same error message again. Also, there unfortunately doesnt seem to be a roll back facility in System Mechanic either. Apart from that everything else is OK - other USB devices work OK and so on. Anyone any ideas cos I'm absolutely stumped?

  ardvarc 07:42 27 Jun 2003

After I had problems installing 760 when I converted to XP Home last year I had to download XP drivers and software from Epsom support for my 760. I cleared out all references to Epsom first.

click here

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

These brilliant Lego posters show just what children's imaginations are capable of

Mac power user tips and hidden tricks

Comment réinitialiser votre PC, ordinateur portable ou tablette Windows ?