Printer Drivers disappear

  old-timer 11:34 01 Apr 2009
Locked

Recently, I have started losing my printer driver whenever I shut down my PCs

There are three PCs on a wired network with three printers. Two printers are connected to the network via a Linksys parallel print server, and one through a Belkin USB print server. Until recently, everything worked fine, then one day I booted up and found that the printers on the Linksys were greyed out. I re-installed them and things were fine for a few days then it happened again. A few days ago I found that I lost contact with these printers every time I closed down the PC. It has also started happening with the USB Printer a couple of times, but so far not every day.

Is it the printers? Seems very unlikely since they are all affected.

Is it the PCs? Initially seems likely since it appears to be that the printer drivers (not the print server drivers) get lost, but then again it seems very unlikely as it happens on all PCs.

Is it the printer server? Seems very unlikely as both servers have been affected to greater or lesser extent and, anyway, everything works fine once the printers are re-installed, at least until I shut down.

Is it the Network? Seems very unlikely since it works perfectly in all other respects and I have tried swapping cables etc.

Is it Windows XP Pro? Initially this was my favourite simply because I have recently reinstalled completely new versions with SP3, but then why did everything work for several weeks at first?

Is it some automatic update? Seems unlikely because I have gone back to a clone of the newly installed system and this has not cured the problem.

Is it SP3? Now there is a question as I have heard comments that some aspects of SP3 introduce incompatabilities with some kit.

I am at a loss.

I seem to remember reading of someone with a similar problem some months back, but I cannot find the reference.

I could re-install my old copy of XP and sequentially add each service pack to see if that makes any difference, but first I thought I might seek the advice of the experts.

Any ideas please.

  Graphicool1 11:58 01 Apr 2009

What changes (other than adding SP3) did you make to your PC's before this phenomena started happening?

You could always uninstall SP3. Reinstall the latest version. Then reinstall your printers.

  old-timer 13:53 01 Apr 2009

Changes? None, and to make sure I had not forgotten something I reloadeed the clone of the original new installation.

How do I uninstall SP3? It came as part of the installation CD and there is no reference in the "remove software" wizard. As I see it, I would have to get out all my old discs and start again pre SP1 then sequentially reinstall each SP 1-3. I suspect that I might have to do that but if you know a better way please let me know

Cheers

  old-timer 14:28 02 Apr 2009

Thanks folk, I knew I could rely on someone to offer support.

Anyway, I think it is solved, at least until the next time. If anybody is interested, the problem appears to be in the port allocation. This model of Linksys printer server has always been a bit awkward judging by some of the comments on the web when I first bought it many, many moons ago. However once up and running it generally behaves itself.

Sometimes it instals the ports as s simple print server and sometimes as LAN Manager. I do not understand the subtle difference but he printers only work on one or the other and it is a matter of trial and error to find out what sort of mood it is in on the day, but once installed it generally works fine. On this occasion it wanted to install the LAN manager port which worked happily for a few weeks, but why it should change its mind is beyond me and now it only responds on the simple print server port.

Interestingly, having resolved this, the USB print server immediately started to respond again

  Graphicool1 14:10 05 Apr 2009

Thanks for the feed back.

Scroll to the bottom of this page.
On the right hand side click the little box, next to the 'Resolved' button.
Then click 'Resolved'...
...till the next time, cheers :¬]

  old-timer 14:37 06 Apr 2009

Oops, sorry, thought I had done that
Cheers

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best phone camera 2017

Stunning new film posters by Hattie Stewart, Joe Cruz & more

iPad Pro 10.5in (2017) review

28 astuces pour profiter au mieux de votre iPhone