Print Spooler not Running

  aich 19:02 26 Aug 2007
Locked

Help Please!
I have a printer (HP 940c) connected to my network with a HP Jetdirect box. I have been printing OK today but suddenly, when I tried to print from IE7 my PC told me I had no printer installed. When I checked all printers had disappered, including fax. When I try to re-install printers I receive error message that Print spooler Servic not running. When I checked service in admin. tools it shows now that it has terminated 6 times. (i can restart it but then it stops wehn I try to install printer.) I have deleted .tmp files but can't see any files in the spool folder.

  radi8or 08:05 27 Aug 2007

aich,

Pardon if teaching granny to suck eggs.

Run antivirus/spyware progs just in case,
In Services ensure spooler is set to auto and
Remote Procedure Call is running,
are drivers for printer etc. all ok (Device Manager)
Run sfc /scannow (note space) if you have windows disc, there are a few files that make up the spools folder.
If all else fails maybe a windows repair ?

Sorry have no knowledge of Jetbox or if it could affect spooler problem.

HTH if nothing else will bump you up.

Regards Bob

  aich 15:35 27 Aug 2007

Thanks for your help.

I had run virus check but result was clear.

Tried a scan of windows files following your note, and some drivers were replaced. Print spooler still kept terminating.

Downloaded and istalled current drivers for JetDirect from HP site, and all icons returned under printer and fax.

  radi8or 16:04 27 Aug 2007

So are you sorted then ?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best phone camera 2017

Stunning new film posters by Hattie Stewart, Joe Cruz & more

iPad Pro 10.5in (2017) review

28 astuces pour profiter au mieux de votre iPhone