PrimeFilm 1800u Scanner unable to start-up

  peter99co 12:41 16 Mar 2010
Locked

Installed by USB connection and downloaded new XP driver from Jessops Website.
Device Manager shows it is working OK.

The Image software allows it to be selected as a scanner but when it tries to initialise it a message shows it fails to find it and suggests a cable check/power on check.

It is connected and switched on and the found hardware message has run its course and reported ready to use.

Any idea what I am missing?

  northumbria61 13:32 16 Mar 2010

Hi peter99co - take a look at this - you should be able to select your scanner from the list. Read carefully first.

click here

  Sea Urchin 13:46 16 Mar 2010

Make sure you don't have the scanner connected when installing the driver until prompted to do so.

  peter99co 14:54 16 Mar 2010

Thank you for your info. The driver was installed but microsoft did not really like it because it was unsigned. It installed anyway and the device was then powered up.

There is no yellow triangle in device manager so it looks ok.

I may download a new driver from you link.

I will let you know.

  peter99co 16:13 16 Mar 2010

Fixed after three attempts. Had to run the update.exe as well. Even though there were no yellow warning triangles. It is hard to know when to have the scanner switched on. It used to not get picked up if it was switched on after startup.

  peter99co 17:56 16 Mar 2010

It was previously attached to an ME set-up and was thought to have been out of date. That has saved me a few bob for a new scanner

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

Awful clip art from 1994 is being tweeted every hour by a bot

iPhone X vs Samsung Galaxy Note 8

Les meilleurs navigateurs internet 2017