Primary Master Not Installed! Please Help!!!

  Mezzo 21:57 30 May 2003
Locked

Hi There!

My cousin at Uni in Southampton has a TIME Family 400 pc with Windows 98. He has just tried to boot his pc but the hard drive isnt found. He's run an autodetect within the bios and nothing is found apart from the cd rom drive. Strange thing is, he can run dir in the command prompt and see all his stuff.

Any ideas on the please? He has a presentation to do next week and all his stuff is on the mystery drive!

Thanks very much for any help given.

  woodchip 22:06 30 May 2003

He could try a new Ribbon cable

  Mezzo 22:07 30 May 2003

whats that (apologies for my ignorance!)?

  woodchip 22:09 30 May 2003

PS the cable plug's may have worked there way off the pins with changing heat switching on and off. Tell him to try pushing the plugs on at each end of cable

  Mezzo 22:11 30 May 2003

thanks for that woodchip. so it is possible to see c drive with a dir command put appears not installed on bios?

  woodchip 22:15 30 May 2003

The cable may use another signal wire from dos. The ribbon cable is the wide cable connected from Hard Drive to Motherboard He needs to check each end is pushed fully on to the pins

  woodchip 22:16 30 May 2003

PS it only goes on one way red tracer wire next to power cable that cannot be reversed

  Mezzo 22:18 30 May 2003

thanks very much for your help woodchip. he'll open it up tomorrow so fingers crossed. will refresh if problems persist! thanks again.

  Bandy 00:35 31 May 2003

Had a similar problem with another Time machine the other day, with a 440bx motherboard, and found that in the bios it was possible to switch the ide controler to primary only, secondary only, or both.

It was the first time I'd noticed this and it had me fooled at first.

  DieSse 00:52 31 May 2003

It won't be the cable - the operating system does not affect the way the drive communicates to the motherboard over the cable.

1) The drive is clearly not being recognised correctly somewhere. You could try repairing the master boot record.

Start with the boot floppy and at the A prompt type

fdisk /mbr

exactly like that. Then try it again.

2) It's also possible you've lost the OS boot information. You could try to replace it

Start with the boot floppy and at the A prompt type

sys c:

exactly like that. Then try it again.

3) You might also try re-installing Windows - this will not affect your data.

4) You could also install Windows on another drive, then put this drive in as the slave, and copy all the data back.


When you say the hard drive is not being found - what is the exact error message, and at what point do you get it.

  Mezzo 09:25 31 May 2003

I think the error message is 'primary master not installed', but I cant check yet as I doubt he will be up yet!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

Alice Saey's mesmerising animation for Dutch singer Mark Lotterman

iPad Pro 10.5in (2017) review

Comment booster votre iPhone ?