Power Surge On Root Hub

  RJA2409 00:06 02 Apr 2011

when i plug anything in my usb ports it says powersurge on root hub or it does not show it up.

also when i plug the power cable in to charge it also says power surge on root hub

please help me i am using one of those pci cards and its a pain in the ****

thanks for reading

  lotvic 00:12 02 Apr 2011

You could uninstall the root hub and then let windows reinstall it click here

  RJA2409 00:25 02 Apr 2011

i done this but it still is doing it.

now when i plug a usb in it does not even go powersurge only when power lead is plugged in

  lotvic 01:00 02 Apr 2011

Have you installed this pci card yourself and can you post a link to show which one it is.

Please explain what you mean by 'plug the power cable in to charge it' and 'when power lead is plugged in'
Do you know your motherboard type and model number?

Just to check, has it always had this problem or was it okay before and has just started to give this power surge message?

  lotvic 01:09 02 Apr 2011

Also need to know what OS is, XPsp3, Vista, W7? and the SP (sp1, sp2 etc)

And are there any onboard USB ports working? Is it an old computer you have upgraded or what?

  Taff™ 08:24 02 Apr 2011

Sounds like a laptop and a PCMCIA or Express Card with a couple or three USB ports on it. Almost certain to be that`s the problem if it was a cheap one.

  RJA2409 09:05 02 Apr 2011

xp pro sp3 is the os. my normal onboard usbs 3 of do not work instead i am using a express card which is annoying as it sticks out its a acer travelmate 2300 series model number zr1

this link is an image of it (not Mine)

click here

  Taff™ 09:29 02 Apr 2011

And what`s the card make & model?

It may be that the Controller for the Express Card has problems but given the symptoms you have regarding "Power Surge", the fact that your built in USB`s have failed and that this laptop is about 7 years old I suggest it is a motherboard problem.

Can you go to Device Manager and expand USB Controllers and tell us if any problems are reported.

  RJA2409 11:42 02 Apr 2011

it is not the card that does not work it its the onboard usb ports 3 of connected to the motherboard when i plug my laptop in to charge it comes up with power surge on root hub

  Taff™ 11:56 02 Apr 2011

You miss my point slightly, whilst it may be the controller for the 3 onboard USB`s it could also be the controller for the card slot.

To check this point out simply remove the express card temporarily and then plug in the power - does it report the same surge?

If you go to device manager as I suggested and expand the USB controllers you should see that there are several.

  RJA2409 12:09 02 Apr 2011

i removed the card and plugged it in the wall and it says power surge on root hub still????

i have already tried uninstalling them all and letting windows reinstall and that has not worked when i plug a usb in it lights up but windows does not say anything

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Best of the Grad Shows 2017: University of the West of England (UWE)

Best value Mac: Which is the best £1249 Mac to buy

Les meilleures GoPro 2017