Possible Winxp DNS issue

  christov 14:56 14 Jan 2008
Locked

Hi guys, first time posting here so I'm hoping someone will be able to help!

I've only had this problem over the past few days and it's really got me stumped. Basically when connecting to websites I get what seems to be a bottleneck, the images and pages load quickly but the computer takes forever to communicate with the website. For example my fastest record opening the microsoft website (click here) is 11 seconds, which shouldnt really be so on a 20mb connection!
I've tried setting MTU values manually to 1500 on both my router and PC, but still no help. I've tried flushing my DNS and doing a /release /renew in the ipconfig and that seemed to help for about 5 seconds, then the same problem kicked in again. The PC connects to a router, which in turn connects to a cable modem via ethernet; I've tried with the pc connected to the router and the modem and still the same problem persists. I get incredibly slow loading times while going into the router/modem config which leads me to believe that it's a problem with the PC.
Speedtests on the internet connection show that the speed is absolutely fine, but this bottleneck is beginning to irritate the hell out of me!
PC is running WinXP pro with latest updates, router is a Linksys WRT54GL running dd-wrt firmware and the modem is a standard cable modem from Virginmedia.
I'd like to stress that I really want to avoid calling broadband technical help from Virgin since its now an 0900 number and just being on hold could cost me several pounds alone! Bring back the 0800 support numbers please!!

Anyway, really hoping someone might be able to help here.
Thanks in advance!

  brundle 16:14 14 Jan 2008

Change your DNS settings to OpenDNS for a day or two. click here

  brundle 16:16 14 Jan 2008

Seems unlikely though, DNS is finished once it's found the right IP address for a page that has no external ads or images. Tried removing and re-installing your firewall (if you use a 3rd party one)?

  christov 16:21 14 Jan 2008

I've got a 3rd party firewall, tried running with and without it and that doesnt seem to help.

Also tried using OpenDNS, but after following the instructions on the site for both computer and router I still cannot get it to see that im using openDNS... any suggestions?

  brundle 16:35 14 Jan 2008

Do you use a huge Hosts file? If it's 100kb> apparently disabling the DNS Client service is recommended.

  brundle 16:36 14 Jan 2008

As for OpenDNS, if you connect the PC directly the modem and manually configure the IP settings using OpenDNS, does it return the correct values when you use IPconfig /all?

  brundle 16:37 14 Jan 2008

Additionally, I've been with Virgin since the days of Blueyonder and page-loading/general speed has been noticeably slower since the change over. But not as slow as what you've described (and I'm only on 4mb).

  christov 16:46 14 Jan 2008

Hosts file is tiny, and I can't get openDNS to work while connected to just the modem.

  brundle 17:05 14 Jan 2008

Hard to eliminate DNS from the equation if you can't use an alternative server. Have you tried a `tracert` to a particular problematic site, using its URL and IP address? Which is faster?

  christov 17:12 14 Jan 2008

no sites are being problematic in particular, but google sometimes takes over 5s to load when it shouldnt. did the tracert with google.com and the IP, google.com was actually faster.

  brundle 17:16 14 Jan 2008

Have you tried switching all your kit off for 10-20 minutes and re-connecting, just to re-establish your connection. Can't think of much else you can try

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

These brilliant Lego posters show just what children's imaginations are capable of

Mac power user tips and hidden tricks

Comment réinitialiser votre PC, ordinateur portable ou tablette Windows ?