Possible DHCP problem setting up Network ...

  Heefie 18:52 30 Jan 2005

Hi all, there's something going on here that I don't quite comprehend. I am using Win2k Professional & am attempting (once again !) to set up a network. However, before getting that far, I need to access the new 3com Router, which should be available on, apparently. It doesn't work, but I think that's because it may not be at that address ...

Now, the little that I do know about Networking is that the IP addresses have to be in the same range, if I do an IPCONFIG, I get the following :

Windows 2000 IP Configuration

Ethernet adapter Local Area Connection: (This is set to Obtain an IP Address automatically)

Connection-specific DNS Suffix . :

Autoconfiguration IP Address. . . :

Subnet Mask . . . . . . . . . . . :

Default Gateway . . . . . . . . . :

Ethernet adapter NVIDIA Network Adappter #2: (This is set to Obtain an IP Address automatically)

Connection-specific DNS Suffix . :

Autoconfiguration IP Address. . . :

Subnet Mask . . . . . . . . . . . :

Default Gateway . . . . . . . . . :

PPP adapter UTV Clicksilver:

Connection-specific DNS Suffix . : (This is set to Obtain an IP Address automatically)

IP Address. . . . . . . . . . . . :

Subnet Mask . . . . . . . . . . . :

Default Gateway . . . . . . . . . :

This looks wrong to me, should these not be in the 192.168.xxx.yyy range ?

If I type in "IPCONFIG / RELEASE" I get the message :

All adapters bound to DHCP do not have DHCP addresses. The addresses were automatically configured and can not be released.

Now, I believe DHCP is going to prove to be my problem here ... but I don't know much, if anything about it, and although if I go into the Properties of the TCP/IP settings (for all of the above) and into Advanced, IP Settings say "DHCP Enabled" & in WINS it says "Use NETBIOS setting from the DHCP Server" ...

BUT ... if I enter IPCONFIG / RENEW it takes about 90 seconds to respond and I get the message :

The following error occurred when renewing adapter Local Area Connection: DHCP Server unreachable, then after another 90 seconds I get the similar message :

The following error occurred when renewing adapter NVIDIA Network Adappter #2: DHCP Server unreachable

If I go into Administrator Tools I have no DHCP option, and if I go into the Windows Component Wizard (within Add/Remove Programs) & into Networking Services I have no option for DHCP, just RIP Listener and Simple TCP/IP Services.

HOWEVER ... within the Administrator Tools, if I check Component Services and Services (Local), DHCP Client has a status of STARTED & Automatic ...

Now ... do I have DHCP or not ?!?!? If not, why not ?!?!? Why are my IP addresses so odd ?!?!? What on earth do I have to do now, most people seem to get a Network up & running in 5 minutes ... I've worked with Computers for 28 years and I can't get one running for love nor money !!!!!!!!

  FelixTCat 19:19 30 Jan 2005

The 169... addresses are issued by Windows when it can find no dhcp server.

If the router is not at the default address, try manually resetting it (often a small button at the rear (like the emergency opening button of a cd)).

Do you have the correct type of cable - straight-through, not crossover?

Routers normally have lights to show connections. Do they light up when you connect your pc to the router?

  Heefie 20:01 30 Jan 2005

Just been informed on Experts Exchange that " Windows 2000 Professional does not serve DHCP" ... so what's with all the DHCP stuff ?!?!? Weird !!!

Yeah, the cable is as supplied with the Router & all the ligts look OK, however, my connection is not strictly as 3com suggest ... the Router tells me to link direct to the ADSL Modem, but my modem links to the PC via a USB & has no other connectivity ports ... so I've ran the link from the NIC card to the Router's Ethernet/DSL port & the lights that are on look fine ... Power is green, WLan is green & Cable/DSL Status is green.

  LeadingMNMs 20:05 30 Jan 2005

Try to manually set the IP address (in the properties of TCP/IP as before). Make sure that the IP address is not the same as the routers, probably best to just add one so and ensure that the subnet mask is the same as the routers (check the manual). The default gateway should be the routers IP address, If you can leave the DNS servers blank, do so, otherwise enter again.

When this is done, in the command prompt type "ping" Does it time out or are all packets recieved ?

  fitshase 20:34 30 Jan 2005

I think the problem lies in the way you have connected your PC to the router. You need to plug the cable into one of the normal ports and not the DSL port. You also need to invest in an ethernet ADSL modem as I do not think the USB one will work in the way you have it set up.

Plug the cable from PC1 into the router's normal network port.

Plug another cable from PC2 into another of the router's normal network ports.

You should then be able to get into the router and it should set all of the computers an IP address.

If all of this works then you need to get a hold of an ethernet ADSL modem and plug it into the DSL port in order to share the connection.

Alternatively, if you are happy to have PC1 (the PC with the USB ADSL modem attached) switched on all of the time then set up internet connection sharing, set it a static internal IP address ( for example) and all of the other computers will look to that IP address for the internet.



  Heefie 20:52 30 Jan 2005

The bases are loaded !!!!

I don't know if this will solve everything, but by moving the cable, as you suggested, into Lan Port number 1, I got straight into the Router & have, apparently, configured it successfully.

I now need to see about setting the Network up on PC2, but that can wait a day or 2, I need to eat !!!

Thanks ... I'll be back .........

  LastChip 21:41 30 Jan 2005

There seems to be some confusion here as to where the DHCP originates.

Your Router should be the default DHCP server. Your computers are the clients, and should be set to obtain an address automatically. The computers will accept the address supplied by your router. It would be unwise to try and mix DHCP servers, as you can almost guarantee conflicts.

In fact, you can place multiple NIC's in a machine and set-up a bridge, but this would be beyond the skill of most home network administrators and you have to have quite extensive knowledge of networks to archive that aim.

The addresses consigned by the router are normally available in a page of the routers configuration known as the LAN Table. This is often accessed via a web based page. Whilst browsing the pages, attention should be given to the (normally) built in firewall, as often the default configuration is wide open, or even switched off, to allow for easy set-up.

There has been a number of threads recently, trying to solve network and Internet Connection Sharing issues and almost without exception they are seen as one. This is not the case. You should treat each issue as a separate entity. If your network is not working properly, there is little point in trying to share a connection.

fitshase's suggestion of replacing your modem is a good one. A proper Ethernet modem will plug straight into your router and will in all probability work without any further effort.

If others read this for future reference, and you have a USB modem, there are routers available that have a USB port for connecting your modem. There are also routers available that have a built in modem, so these are two further options for others to consider.

My own preference, is a single port Ethernet Modem/Router feeding into a fast switch. (A switch is similar to a router but is more efficient and has slightly different characteristics).

  Heefie 00:14 31 Jan 2005

... and it's especially nice to see you write " If others read this for future reference ...", I get so pissed off when I search the Internet for resolutions to problems & the answers given are A) so uninformed as to be embarassing and B) Buy a new one !!!

I had a Netgear router before this, that worked with regard to the 2 PCs talking to each other, but then my ISP had a problem & the NG wouldn't let me back in, even with explicit instructions from NG themselves as to how to do a factory reset !!!

Anyway, that had an inbuilt modem & I wondered if there may be a conflict, my ADSL modem worked within 10 seconds of plugging it in & has never been a second's problem, therefore I deliberately went for the "Router without modem" solution ... I didn't expect all this crap !!!

As I've said before, most people seem to set up a problem free Network within 5 minutes ... is it Win2K & it's lack of DHCP that's the problem or is it just me ?!?!?!?

  Heefie 11:38 06 Feb 2005

I've ordered a new ADSL modem, with an ethernet port in it, so once that arrives I'll see if it resolves the problems ... in the meantime, thanks, everyone, for the help and advice thus far ...

  Heefie 22:46 21 Feb 2005

The new 3com ADSL modem, with ethernet port is installed and I am using it ... haven't tried linking PC2 in yet, as it's freezing in here and I'm going to bed !!!

But, while I'm tucked in nice and warm, perhaps one of you might suggest why the router's ADSL/Cable light is yellow, which apparently means the connection is running at 10Mbps rather than if it were green, 100Mbps ?!?!?

My Router is a "3com OfficeConnect Wireless 11g Cable/DSL Router (3CRWE554G72T)" and my modem is a "3com HomeConnect ASDL Modem Ethernet"

Cheers in advance ...

  LastChip 00:42 22 Feb 2005

How fast is your connection? 512Kb or even 1Mb, significantly less than 10Mb, or are you referring to the connection speed between your computer and router?

The maximum theoretical transfer rate for 11g is 54Mbs, but you wont achieve that. The actual throughput will depend upon many factors not least of which is how far away each device is from each other, and whether there are any obstacles in the way.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review: Hands-on

Illustrator Andrés Lozano on his improv line work, brazen use of colours & hand sketching

iPhone X review

Comment envoyer gratuitement des gros fichiers ?