Plusnet broadband starter problem

  Armchair 16:15 27 Mar 2009

Am trying to connect to Plusnet Value Broadband. Have two phones, one downstairs (master socket), one upstairs. Desktop PC upstairs.

Tried my Speedtouch USB modem first. Couldn't get the DSL light to stay green, just kept flashing. Couldn't connect. Tried all four filters in every combination. No luck.

Tried ethernet Speedtouch router (provided by Plusnet themselves). DSL light stays solid on downstairs phone socket, but not on the upstairs one. Plusnet techie reckons I need to get an engineer to check out my upstairs line. Thing is, I used this set-up without a problem with Tiscali for three years up till August of last year.

Upstairs phone socket looks okay. Wiring in place. Phone works via this socket.

Help, please!

PS Am on library PC till 5pm GMT.

  Clapton is God 16:19 27 Mar 2009

Have you installed the latest drivers for the Speedtouch?

If you're using Vista it will need Vista-specific drivers

  Armchair 16:22 27 Mar 2009

Am using XP.

Haven't connected ethernet Speedtouch to PC yet! Need to get a DSL connection first.

Summary:- modems/routers work on the donstairs phone socket, but not on the upstairs one. They did with Tiscali, though.

  Clapton is God 16:24 27 Mar 2009

Did you also use the Speedtouch with Tiscali?

  Armchair 16:42 27 Mar 2009

Yes, I used the USB Speedtouch modem with Tiscali. I tried it first with Plkusnet, then sent for the ethernet router when I couldn't get connected. I suspect that the Plusnet signal is too weak to work properly via the upstairs (ie Slave) phone socket, but I'm not sure.

Looks as if I'm going to be stuck with a useless 18 month contract, because I have no wish (it isn't practical or convenient) to move the desktop PC downstairs.

  Armchair 16:51 27 Mar 2009

No advice? Must leave soon. Have considered replacing the phone extension lead, but I suspect it might be a waste of time. Anyone else experienced a similar problem?

  eedcam 18:19 27 Mar 2009

Tried plusnets own forum?
click here

  Armchair 19:44 27 Mar 2009

Hello again. Have carted the PC downstairs, and the web is working perfectly. Am puzzled as to why it won't work via the upstairs line, because this connection is smooth as silk. No, I haven't tried the Plusnet forums (yet).

I phoned them back earlier, and I can ordera wireless router from them for an additional £9.99. Not sure if this would solve the problem or not, though.

  Simsy 20:23 27 Mar 2009

As it does work via the master socket OK then it isn't a Plusnet issue... It must be one with your telephone wiring or the filters.

You say;
"Have considered replacing the phone extension lead"... If you have the extention cable plugged into downstairs via a filter, then the ADSL signal wont be getting upstairs... Is this possibly the problem? You should not, (if it's how I imagine!), have a filter in the downstairs socket.

Does this help?



  Armchair 13:11 28 Mar 2009

You were right, Simsy! Got it working now. Just had to get my head around the wiring/socket set-up. I had the upstairs phone wired through two filters.....

Oh well, all's well etc. I got an ethernet router for £7 out of it, lol. Now I can stop bothering those poor Plusnet techies.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Add Depth Of Field to a photo using Tilt Shift Blur in Photoshop

iPhone tips & tricks

Les meilleures tablettes 2017