PLEASE HELP!! DVD drive not found

  ImAFlump 18:13 22 Aug 2006

Following a system crash, my system now won't recognise my DVD drive (NEC6500). The crash happened as I was turning my laptop off. Evertime when I boot up now, I get a black screen asking whether I want to start Windows or Crash Recovery Console. I've checked the BIOS and the DVD drive is not appearing as secondary master drive, although it used to be. In fact it's not registering at all. My Computer within Windows doesn't detect any drive now (nor does Device Manager) and I cannot seem to retrieve it. However whenever I put a disc in the drive, it spins and the light comes on. It's almost like the drive is no longer linked to the motherborad. With it being a laptop, I can't even take it apart to check whether it's the IDE cable that's gone. The BIOS is Insyde Software's MobilePRO and it doesn't have any drive detect option. Could it have anything to do with the firmware?

Please can anybody help?!

Si > : )

  skidzy 19:25 22 Aug 2006

This may help you out ImaFlump :

Restore Missing CD/Dvd Drives

Missing cd/dvd drive
If it is showing an error code, 10, 39, etc., delete the drive.

Then follow these directions for clearing the Upper/Lower Filters: (might want to print this out)

1. Click on Start --> Run --> and type in 'regedit' followed by the enter key
2. Expand the "HKEY_LOCAL_MACHINE" key (looks like a folder) by double clicking it (or
3. clicking the "+" next to it.)
4. Expand the "SYSTEM" Key
5. Expand the "CurrentControlSet" Key
6. Expand the "Control" Key
7. Expand the "Class" Key
8. Please look for a key containing the following string of letter and numbers:
9. High light this key by left clicking once on it
10. On the right hand side you are looking for "UpperFilters" and "LowerFilters" under the "Name" column, once you find these please delete them by right clicking on them and choosing "delete"
11. Please exit the registry by clicking on the "X" in the top right hand corner of the screen

Reboot your computer

Missing cd/dvd drive normally occurs after uninstalling cd burning programs such Nero/Roxio.

Hopefully this will sort your problem.

If in any doubt,please create a system Restore point first as you will be editing the registry.

Good luck.

  ImAFlump 17:46 23 Aug 2006

Thanks Skidzy. Your response was much appreciated.

I tried that, but sadly the drive is not appearing. AsI've never had Roxio or Nero installed, I'm not sure if that's what happened. I remember turning off my laptop one night, however after the Windows logging off screen, it didn't turn itself off like it normallydoes. The screen went blank but stayed on. Ihad to manually power it down, but when I turned it no the next day, I got an extra opion during the tart-up screen (i.e. start Windows normally or go to Recovery Console). When I then got back into Windows XP, the drive had disappeared.

I tried to update the BIOS thinking hat miht detect the drive itself, but Packard Bell only supplies BIOS flash that I have to write to CD and boot from that. Sadly as the drie has disappeared, I can't do this. My laptop has no flopp drive either so I can't boot using floppy disk. My first bootup option (set fom BIOS) is to boot from CD-ROM, but it's not even doing that nowadays It boots straight from the secondary source, i.e. Hard Drive.

I've tried uninstalling IDE controllers, editing the registry, starting Windows using last known settings that worked etc, but nothing works. However the drivestill works...just doesn't interface with Windows or BIOS. I'm beginning to think it may be the IDE cable that connects the drive to the motherboard? Could the crash have caused this i.e. damaged the cable?

A beer for whoever can hlp me!!


Si > : )

  skidzy 17:55 23 Aug 2006

Not sure if this will help click here Sorry got to go out for an hour,will try to help in a while.

Good luck

  ImAFlump 18:24 23 Aug 2006

Thanks again Skidzy. I took a look at that and i seems fairly complicated. As far as I'm aware, the firmware is still the original.I've read that flashing the firmware could ernder the drive totally useless if done incorrecly?

I also noticed earlier (during the boot-up sequence) that the BIOS found the hard drive as primary master with nothing as primary slave (which is correct). However when it moved onto secondary master, it just pasued and then left it blank before moving onto secondary slave...which again was blank. This seems to suggest the the drive isn't connected to the motherboard. Could a crash or configuration problem have have caused this? Or is it simply a case of the IDE cable needs to be replaced? I've put desktop PC's together before, but never taken apart a laptop, so am unsure of whether to risk trying a new IDE cable.

Thanks again Skidzy.

This issue is starting to drive (no pun intended) me mad!!

Si > : )

  skidzy 19:52 23 Aug 2006

ImAFlump..In fairness,i think ive done as much as my knowledge will let me and would not like to mislead you.Im not familar with the insides of a laptop and what i hear can be pretty difficult.

Maybe others can offer futher advice,but i guess it will be trip to your local pc man or shop.

If i can find any more info that may help,i will let you know.Sorry i can not help further.

Good luck ImAFlump

  skidzy 19:56 23 Aug 2006

Found another link that may just sort you out,though im not holding my breath. click here

Good luck

  ImAFlump 15:53 24 Aug 2006

Thanks for all your help Skidzy. Really appreciate it. I'm gonna try Packard Bell Tech Support, other than that it's a case of taking a trip to PC World (reluctantly)!!

Can anybody else help?!

Si > : )

  Fruit Bat /\0/\ 16:17 24 Aug 2006

This seems to suggest the the drive isn't connected to the motherboard. Could a crash or configuration problem have have caused this? Or is it simply a case of the IDE cable needs to be replaced? I've put desktop PC's together before, but never taken apart a laptop, so am unsure of whether to risk trying a new IDE cable.

1. check in BIOS that IDE secondary controller is "enabled"

2. Try removing and refitting the laptop dvd drive it may just have jarred loose.

  ImAFlump 18:15 24 Aug 2006

Heya Fruitbat, thanks for the post. The only think I can think of is that wehen my laptop crashed, it caused a configuration problem. Sadly the BIOS is so lame that there is nothing that will enable me to detect or "enable" secondary IDE controller. When I go into BIOS screen, it just says:

Primary Master: HDD
Primary Slave: (blank)

There's i no mention of the secondary IDE, which is bizarre, cos there used to be.

Am thinking it's the IDE cbale, but want to exhaust all avenues before cracking that badboy open.

I'll give it a whirl and report back. Thanks again.

Si > : )

  Fruit Bat /\0/\ 18:19 24 Aug 2006

You will need to look under something like Advanced Peripherals in the BIOS for the IDE channel settings.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

Halloween Photoshop & Illustrator tutorials: 20 step-by-step guides to creating spook-tacular…

iPhone X news: Release date, price, new features & specs

Comment créer, modifier et réinitialiser un compte Apple ?