PIO mode - again...

  Ian in Northampton 16:00 22 Jul 2010
Locked

As recommended by the gurus (thanks guys!) on here, tomorrow, I'm swapping out my 40-wire IDE cable for an 80-wire cable to try once and for all to get my DVD drives back to DMA mode and out of PIO mode, having tried everything - but everything - else.

But if that fails, I have a desperate last ditch plan: I'll wipe the system and reinstall XP. Surely - SURELY - unless it's a BIOS issue (which I've investigated and found nothing amiss) that will fix it?

  Ian in Northampton 16:14 22 Jul 2010

Sorry: for the whole sad story see here

click here

and here

click here

  Ian in Northampton 08:29 23 Jul 2010

Unashamed bump...

  karmgord 22:52 23 Jul 2010

what os are you using as xp only tries DMA mode a certain number of times until it only uses PIO mode.

  woodchip 22:57 23 Jul 2010

it is a 80 wire problem

  karmgord 23:28 23 Jul 2010

Uninstall the ide channel under windows device manager(primary or secondary).Restart the computer and let windows xp install again the driver.
Try also the registry edit.(this should stop forever the downgrade option of windows xp)
start-run-regedit-navigate to
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\000X

look in each 000X for "MasterIdDataCheckSum" or "SlaveIdDataCheckSum"
right click and delete them.

0000 is the IDE master controller (nothing to tweak here)
0001 is the primary IDE channel
0002 is the secondary IDE channel

microsoft says about this problem:
click here
solutions:
click here
click here

SET A RESTORE POINT & BACK UP THE REGISTRY FIRST.

  rdave13 23:38 23 Jul 2010

If all advice fails then reinstall XP if a retail disc and you have a motherboard drivers disc. Just backup all your docs,photos etc., will be quicker I think.

  Ian in Northampton 17:29 24 Jul 2010

Karmgord/Woodchip/RDavw13: many thanks for your replies. Sorry not to have responded earlier, but I’ve been offline for 36 hours…

Are you sitting comfortably? I think I’ve given up on this. I absolutely hate it when things don’t work as they should, but for the sake of buying an external USB DVDRW drive for £30, there’s no point in continuing. Well, I just have one more thing to try…

To start at the beginning. I got the 80-wire IDE cable recommended by Woodchip. Friday morning, I went to install it. The bloody thing was too short to enable me to attach both DVD drives. Oh well, I thought, I’ll plough on with just the one drive connected, see what happens.

I decided on a fresh install of XP yesterday evening when the new cable didn’t make any difference. I couldn’t get the PC to boot from the known-bootable XP CD. I remembered, I now only had one drive attached, and wondered whether that was the one set in the BIOS to boot from first. So I opened up the case, and refitted the old IDE cable so I could use both drives. Wouldn’t boot from either drive.

After much messing about in the BIOS, got it to boot. Did the fresh install. Four times. Each time, at every stage of the installation – e.g. after loading motherboard drivers, after loading graphics drivers, after loading sound drivers, after loading SP2 – I would check to see whether the drives were in PIO mode. Each time, they weren’t, and they weren’t – and then they were, no matter in what order I installed everything. At some random point in the install, the drives would flip from DMA mode to PIO mode.

Finally, at 10:00 – success! A clean, complete XP install with both DVD drives in DMA mode. Yay! Went to bed a happy man.

Came down this morning to load Office. Checked to make sure both drives still in DMA mode, then began. Noticed immediately that the mouse was jerky – a sure sign of PIO mode when you’re loading from a drive. Sure enough, the drives were back in PIO mode.

Tried everything again that I’d tried before – running resetdma.vbs, toggling the DMA/PIO option, uninstalling the secondary IDE channel and so on – and also Karmgord’s registry hack. Nothing – no change. Stuck fast in PIO mode.

All of which has led me to believe that this is a hardware issue, not a software issue. I have a proper length IDE 80-wire cable on order and, when I have it in hand, I’ll try again and do another fresh XP install. And if that doesn’t work, I have to conclude that, strangely, it may be some kind of motherboard hardware error that means each time XP looks at the secondary IDE channel, it marks it as bad. In which case, there’s no solution as far as I’m concerned.

Unless you have other ideas…

  Fruit Bat /\0/\ 17:40 24 Jul 2010

Re-enable DMA using the Registry Editor

Run REGEDIT. Go to the following key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}

It has subkeys like 0000, 0001, 0002, etc. Normally 0001 is the primary IDE channel, 0002 the secondary, but other numbers can occur under certain circumstances. Check the DriverDesc value to see which one it is.

Delete MasterIdDataChecksum or SlaveIdDataChecksum, depending on whether the device in question is attached as master or slave, but it can't actually hurt to delete both. Reboot. The drive DMA capabilities will be redetected.

Open Device Manager again and check whether the device is now actually using DMA mode. If so, congratulations, you've made it (at least until the next time Windows disables DMA).

DMA Reset Tool
click here
will do it for you.

Alternative Method—Uninstalling the Port
1. Uninstall the secondary IDE port
To do that, open Device Manager as follows. Right-click on My Computer, select Properties, click on the Hardware tag, click on the Device Manager button, click on the plus sign to the left of IDE ATA/ATAPI Controller, right-click on Secondary IDE Channel, click on Uninstall. Deactivating is not enough.

Reboot to make the changes active and permanent.

After booting Windows will automatically reinstall the IDE channel and the DVD (or CD) drive. This Plug-n-Play process can take a little while, so give it a minute after the boot process finishes.

2. Reactivate DMA
But this is not enough, because unfortunately Windows does not automatically activate DMA on a DVD or CD drive. You have to tell Windows to try to use DMA first.

For that, go to Device Manager again. Right-click on My Computer, select Properties, click on the Hardware tag, click on the Device Manager button, click on the plus sign to the left of IDE ATA/ATAPI Controller, double-click on the secondary IDE channel, click on Extended Settings and change the relevant setting from PIO only to DMA when available.

On Windows NT and 2000 you now have to reboot a second time, but Windows XP applies the change instantly. Then you can go to the same place in Device Manager again and check whether the device is now actually using DMA mode. If so, all is well.

3. Driver is not intended for this platform
If you keep getting the following error message:

There is a problem installing this hardware.

IDE channel

An error occurred during the installation of the device. Driver is not intended for this platform.

then the way out is to rename C:\WINDOWS\system32\drivers\atapi.sys (or a similar path on your computer) to something like atapi.old.

If that's not possible, you can try it from the repair console (boot from the Windows install CD and select the repair console).

If Windows always automatically recreates atapi.sys, you can try renaming it in safe mode or from a command line window or you can try to rename or remove it in the driver cache as well.

Desensitize Your Computer's IDE Channels
There's a bit more to it. The following article offers a way to reduce the incidence of this problem, although it still doesn't solve it altogether.

IDE ATA and ATAPI Disks Use PIO Mode After Multiple Time-Out or CRC Errors Occur
click here

Do read this article because it contains a useful long-term workaround. But you have to go through the procedure described here to re-enable DMA first. Assuming you've done that, insert the ResetErrorCountersOnSuccess registry values mentioned in this article into both the primary and the secondary IDE port registry keys as described.

Unfortunately this is only a half solution, because when you enter an unreadable DVD, you will get 6 errors in a row, and the IDE channel will revert to PIO mode, but at least when you pull out the DVD in time and then insert a good one, the error counter will be reset and it will at least be a bit more difficult for Windows to hobble your IDE drive.

  woodchip 17:59 24 Jul 2010

When you tried fitting the Optical Drive on its own did you change the jumper to Master on the drive

  woodchip 18:00 24 Jul 2010

PS in BIOS the drive would also need to be set to Auto

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Microsoft Paint set to die after 32 years

Mac power user tips and hidden tricks

Comment désactiver la saisie intuitive et paramétrer votre clavier ?