BBez 17:10 30 May 2004

having problems with my system.

When i ping localhost or, 6 out of 10 reboots, i get no reply.

Tried 2 other NICs, Different PCI slots with all 3 NICs, loaded fail safe defaults and optimised defaults but get same result with all NICs...

any suggestions, thanks in advance...

Gigabyte GA-7VA v1.0 mobo...

  Rob_E 17:25 30 May 2004


I'm no network expert but...

If you can't ping the loopback address then it sounds like a problem with the tcp/ip stack, not your NIC - pinging doesn't send anything to a NIC, just tests the tcp/ip stack

try re-installing your networking software (control panel, add/remove, dial up networking)

  Graham ® 17:27 30 May 2004

And for those who don't know what ping is

click here

  Taran 17:36 30 May 2004

The loopback ping only checks to see if TCP/IP is correctly initialising.

I've lost count of the times I've heard, read or argued about whether or not it checks if the NIC is working.

It doesn't.

You can successfully use the loopback ping on a machine with no NIC fitted. I've done so several times when the equipment was on hand and a particularly stubborn individual refused to take my word for it. Often a student who thinks they know better is the most difficult to convinc. If they won't take my word for it I rip the NIC out of a test machine, boot it up and watch the loopback ping do its thing. This normally goes some way to convincing them.

Reinstalling the TCP/IP element of your network software is the quick fix that normally works. You don't have to play with any of the other features as a rule.

Without knowing your operating system you could go any one of several slightly different routes to sort things out but if you open your control panel and right click on the My Network Places or Network Neighbourhood icon and select Properties, now right click on the device connection and select Properties, then left click once on Internet Protocol (TCP/IP) and choose the option to unistall it.

Restart the computer and follow the same stpes as above but this time select the option to install Internet Protocol (TCP/IP).

Check it out and all should be well.

Just one point and don't take this the wrong way: make sure you only use a command prompt for your ping checks.

A friend was having awful problems once and it turned out he was using Internet Explorer and kept getting the MSN error page with a prompt to search...


  BBez 17:55 30 May 2004

cheers all for the replies, Taran, yes, been running the ping from "cmd" at the run prompt but will try reinstalling the TCP/IP stack...let you know...

  BBez 19:01 30 May 2004

right, reinstalled tcp/ip stack using Tarans method, rebooted and still same problem, then tried "netsh int ip reset c:\resetlog.txt" from cmd prompt. also fails

System setup as PC1 (main that i use) as PC2 (backup & docs) as both on subnet.

Can ping from PC1 to PC2, everytime, but pinging from PC2 to PC1 brings up "dest host unreachable".

Both on "BEEBYKES" workgroup...

also tried new "CAT5e straight through" on my switch...which i've rebooted...

x-over not having it either so i'm sure it's not the switch as it passes self test on power-on...

now running same username & password to eliminate permission errors...

set PC2 to allow everyone "full control"...

about to take a hammer to PC1, built it myself, been cheaper going to PCWorld...

  Taran 19:21 30 May 2004

More fun too by the sounds of things...


Have you tried ipconfig/renew

The trouble with network problems is that it can be any one of dozens of things. I've had networks where eveything was set as it should be but they stubbornly refused to work. Changing the computer names or the workgroup name solved the problem, but to all intents and purposes there shouldn't have been a problem to begin with.

You say you're using a switch.

Do you mean a router ?

If so, set it to deliver DHCP (normally its default setting) and set your network to get its settings via DHCP. Reboot all machines and see what happens.

If it isn't a router ignore the above.

Is this a new problem or has the network regularly had issues ?

  BBez 20:26 30 May 2004

thanks for the suggestion, not a router, just a 10/100 switch connecting 2 PC's. Had Mandrake 10 dual booting on PC2 and since i uninstalled it but rerunning Mandrake setup, deleting the mandrake partitions, booting with 98se Boot Disk and running "fdisk /mbr", nothing but problems.

Renewed w/groups...

Enabled DHCP from PC1 to PC2 as i've got ICS for PC2 on a dial-up...

not being funny, but, just got my BSc in Network Computing so this subject is a "tragic comedy" as i've configured Cisco VPN's for an exam...

  Taran 20:42 30 May 2004

You'll forgive my vast amusement I hope...


I hate to say it but have you considered a clean install of Windows from scratch with no Linux in the mix anywhere at all ?

Download a startup disk image from if you don't have a usable clean boot floppy yourself.

Better yet, download MaxBlast as well click here

Write a new boot floppy using the download you get from and use MaxBlast to prepare your hard disk.

MaxBlast is drive overlay software at its very best. You can partition and format a huge drive in seconds (literally), but you will need an OS startup floppy to make the hard drive bootable.

It does sound as though you may have some Windows instabilities going on and I'm wondering how many of them may be due to a confused or less than optimal installation of Windows.

I have a general rule of thumb that if it takes me more than an hour to fix a fault it's time to start afresh from a known point. Cleaning up a mess is far harder than starting from scratch.

Sorry to get radical so soon but we could go round and about for days here and still get nowhere fast.

  BBez 20:56 30 May 2004

know what you mean Taran, thanks for your continuing advice...

will probably do that as the kids are in the garden smashing up wood with my hammer at the moment, lol :~)

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review

How to draw a mandala

iPhone X review

Les meilleures enceintes Bluetooth à moins de 150 euros