Pau1JB 17:35 21 May 2004


I got a Klahowya script which is a year book.
And i got it all finished. and working with a few problems.

I cant acess admin, i looked on the forum on the site and soem guy had the same problems as me and to fix it he added trailing slashs which he forgot to. this was in the config.php at a bit $filepath =.

the thing is i think is wrong with me is, i havent even entered anything into this feild. cause i dont know what its abouit. above it says.

// Enter the path to the klahowya files folder on your hard disk
// for windows, use double backslashes like c:\\inetpub\\wwwroot
// for OS X, use the path i.e. /Library/WebServer/Documents/klahowya/files/
// Please note that the path is cAsE sensitive

then it lets you enter the path.

what is it?

i have a plus net account, in which they let me have php and my sql. i have done everything else. this is the only bit stopping me.

btw i know nothing or very little about php.


  Taran 18:05 21 May 2004

Copy and paste this into it:




Now, make sure when you save it that you select the Save As option and save it as phpinfo.php

Note the .php file extension. Sometimes you find that Notepad gives you a double barrelled file extension like phpinfo.php.txt and if it does, just rename it to phpinfo.php

Upload the file to your web space then call it into your browser with http: // www. your site name .

You'll get a very long page full of all kinds of intereting things.

Use Find (Ctrl, F) and search for this variable: DOCUMENT_ROOT

Just to the right of where it says DOCUMENT_ROOT there should be something very roughly along these lines:


Try using this as the document path in your script, since that is the folder location of the virtual web on the web server where you site lives. Make sure you copy and save it since any error or type will disallow the script from running at all.

If it works, great.

Delete the phpinfo.php file from your web space.

If it doesn't work, post again.

  Pau1JB 22:24 21 May 2004

i can find anything along u lines of "/homepages/36/d85027736/htdocs", all i got was any one of these two.


the problems i have is i cant log in to admin. secondly, it just cant load the pages when u click on a letter to view profiles of that spefic letter.

thanks any help would be good.
i managed to set everything else up ok. just this gives me hassle.

  Taran 00:09 22 May 2004

In my last post I said "there should be something very roughly along these lines", and then I listed the /homepages/36/d85027736/htdocs file path.

Your DOCUMENT_ROOT : will not be the same as that, but will follow a similar structure in that it will be a series of locations on a file system divided with slashes, like this:


My example of /homepages/36/d85027736/htdocs is from one of my own web server accounts and just like a username and password, yours will be different to mine.

Whatever the phpinfo.php listed next to DOCUMENT_ROOT : under the Apache Environment subheading is the path you should try in your script.

When the instructions for your script mention c:\\inetpub\\wwwroot that refers a Windows IIS server while OS X is the Apple operating system used on Apple Mac computers which runs a version of the Apache web server. Both are meant as examples to illustrate the filepaths on alternative systems and how they differ. They are not meant as working examples for every installation.

Try the script with one of the results you got from your phpinfo.php file. Edit the relevant configuration file, upload it to your web server and test it. If it works, enjoy it. If it doesn't, try the other one or email your web host and ask them for the document path of your account. If you have the Klahowya script in a dedicated folder just add the folder name onto the end of the filepath.

Think of it as a web server equivalent of C:\Program Files\Microsoft Office. All you are doing is telling the configuration files where to look for the supporting files they need to run properly.

  Pau1JB 11:07 22 May 2004

I tried both of them and still no luck.

any ideas.

the support on there web site click here is bad, i dont understand half of it.

  Taran 12:59 22 May 2004

I've just downloaded it and installed it to one of my own servers and it's working first time.

I think you'll find that the support is not necessarily bad; it just assumes that if you want to mess around with the script then you have at least a passing interest in PHP and some experience of how to configure settings in PHP scripts to reflect your web server.

Why not email your web host and ask them for the information you need ?

Explain the script you are using and tell them it asks for the filepath to the script. At least your host should supply your web space file path.

  Taran 13:36 25 May 2004

Well, I guess I should offer my apologies. The fix for this one is, in fact, drop dead simple and in my haste to test it on my own server I omitted one vital detail.

Just add two forward slashes to the line that reads:

$filepath ="/home/waxgeek/public_html/ncce/klahowya/files/";

So that it looks like this:

//$filepath ="/home/waxgeek/public_html/ncce/klahowya/files/";

This comments the line out completely and stops the web server from trying to find the files on your local PC. This line is for when you run the system on a local testing server like Microsoft IIS or Apache on your own computer, in which case the server needs the filepath on your local system.

You don't need either of the examples (Windows or Apple Mac) in the $filepath = line, since this is on a live web server and not a local testing server on your own computer.

Sorry to have taken this long to point it out, but all I did was tweak the lines I needed to, upload the whole lot and it worked like a charm. It never dawned on me until today that you would have problems declaring the local testing server information as well as the web addresses of the install and site directories.

This is the nature of PHP scripting - I sometimes forget to point out the obvious when I take it for granted that you are on a local testing server and not a live site, or vice versa.

There we go.

  Pau1JB 14:00 25 May 2004

and when i try to upload a picture i get teh following

Notice: Undefined variable: filepath in /files/home3/pauljb/yearbook/student/profile_update.php on line 69

Notice: Undefined variable: filepath in /files/home3/pauljb/yearbook/student/profile_update.php on line 73

Warning: copy(test.jpg): failed to open stream: Permission denied in /files/home3/pauljb/yearbook/student/profile_update.php on line 73

i had changed it to the document path u mentioned early and it it was all working fine apart from when you went to view the profile it would give a error in db-functions script at line 16 or some.

see here for what my new problem is and thanks for the help.

click here

  Pau1JB 14:03 25 May 2004

its the yearbook on my site.

click here

admin admin is for the admin panel if u need.

  Taran 14:29 25 May 2004

I've just created a new user account on your system and uploaded a sample image without a hitch.

You could check the permissions on your folders and make sure that those that need to be writeable are. You can't upload to a storage folder unless it is writeable on the web server.

Try the dedicated support forum for this product on the Sourceforge website. There are a lot of questions and answers already posted there and you may find some assistance.

The trouble is, I can only guess how you uploaded, how you set things up, how you set file and/or directory permissions from their default and so on. There are a lot of variables in uploading and configuring PHP scripts. The program works fine on my test server though, and took mere moments to set up.

  Pau1JB 14:37 25 May 2004

the problem is only when u try viewing the profile.

and i set my directory for files to 777.

try it


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iPhone X review

How to find a font: Discover the name of a typeface with these apps

The best iPhone for 2017

Les meilleurs logiciels de montage vidéo gratuits (en 2017)