PhotoPlus Problem

  Mananin 15:23 28 Feb 2004

I know you chaps out there like a challenge. Here’s one for the boffins.....even Serif seems beaten.
System is Windows 98SE and problem is with Serif PhotoPlus 8.
The prog. was purchased and installed October 2002. Everything worked fine and I experienced a steep learning curve getting used to editing images by resizing, adjusting, exporting into various formats, layering etc. Only slight inconvenience was that PhotoPlus saves to its own default format...Spp. I then have to "export" to another format (bmp, jpg, tif etc.) if I want others to view the file.
Therefore I have quite a few pre-doctored images from scanner or digi camera in Spp format.
For no known reason PhotoPlus has taken upon itself not to recognise this format and an error message “Unexpected file format” is displayed. The prog will quite happily open other formats but not Spp format.
I have tried reinstalling from the CD by over change. I have uninstalled the whole prog and reinstalled at a new change. Even tried it in my second hard change.
Been in contact with Serif support and tried some suggestions re association of files. But after several discussions (by email) they seem to have given up!
With great trepidation I looked at the Registry and deleted a reference to PhotoPlus and 8 ......didn’t make any difference.
From an old PCAdvisor I followed a method of associating a file using “Open with...”.
Did find the following Error message:
PHOTOPLS caused an invalid page fault in
module MFC42.DLL at 017f:5f415184.
EAX=005d6358 CS=017f EIP=5f415184 EFLGS=00010202
EBX=00e5f7f0 SS=0187 ESP=00e5f738 EBP=00e5f798
ECX=0000000d DS=0187 ESI=00000000 FS=0f97
EDX=8190e8cc ES=0187 EDI=02ef3240 GS=0000
Bytes at CS:EIP:
8b 06 6a 01 8b ce ff 90 d0 00 00 00 8b 45 08 83
Stack dump:
00000081 02ef3240 00e5f7f0 00000000 00000000 00000000 00000000 00000000 00000000 40cfc000 00000000 5f4a1070 00000200 0000000b bff55bcd 00000000
That means nothing to me.

The last suggestion from Serif is as follows:

“If this does not fix the file then the following should generate a new one. Uninstall the program in Add/Remove Programs and then reboot - press F8 for advanced start-up options and enter DOS-PROMPT_MODE (use a boot disk in Windows ME):

You should see C:\Windows>_

Type in CD SYSTEM and press RETURN

You should see C:\Windows\system>_

Type in REN MFC42.DLL MFC42.BAK and press RETURN

Type EXIT and press RETURN

Ignore any error messages you get when restarting Windows

After Windows has restarted, end ALL background tasks (CTRL+ALT+DEL) except Explorer

Reinstall the program.”

As this would appear to be tampering with the “system”, and might cause a fault I would not know how to deal with, I would appreciate comments from “The Informed” that to proceed should be OK.

Apologies for long posting

  britto 19:57 28 Feb 2004

click here
the metion of a patch may be of some help.

  Mananin 15:39 29 Feb 2004

Thanks for tip, will follow up.
(Don't you move down the line fast these days!!)

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Lightwell software lets you create mobile apps without using code

Best value Mac: Which is the best £1249 Mac to buy

Comment désactiver les programmes qui s'exécutent au démarrage de Windows 10 ?