Philips DVDR 1640, comms problems

I have the above drive that lately refuses to work in my PC. It states a communication error?
I have tried the drive in another pc and its working fine, both reading and writing.

Has anyone any suggestions?

Regards
[email protected]

  Z1100 19:58 09 Jan 2007

click here This drive is identical to my drive and I love it.

Hanx!
K.

  archir123 20:01 09 Jan 2007

have a looki in device manager see what it says about it there

just incase you dont know how to get there goto control panel , open the system icon , click the hardware tab then the device manager bit

under dvd/cdrom drives there is a plus sign , open it up and you'll see your dvd type thingy , delete it and reboot (this will re-install it automatically) if your still ahving a problem go back to device manager but this time your ide/atapi controllers , your primary and secondary ide channel ( one of these controlls your dvd) as i dont know which one controlls your dvd (probably the primary) delete em both and re-boot , when it boots back up give windows some time to re-install em and then check yuor player again

im assuming you have win XP if not you'll have to wait for someone who knows what their on about ;0)

will give it a try

[email protected]

archir123

Yes I am using XP.
Tried and failed I am afraid, the drive's still not working. thats to say its reading but not writing.

[email protected]

  archir123 18:33 10 Jan 2007

you never said it was reading and not writing :0/

how about your software (burning program) have you tried using windows media player instead?

As I said in my first thread The drive works fine when it was put in another PC, it just does not want to work in mine. Sorry it may not have been very clear.

It has worked in mine in the past, but I don't know why it suddenly stopped working??

I have tried Nero, WMP, and some free programs off the net but none seem to work.

[email protected]

  OldBlossom 16:11 24 Jan 2007

I have a PC with both windows ME and XP. My DVD drive, which I use for reading and writing all disks and installing software etc., has suddenly stopped reading disks in windows XP, but still works perfectly in ME. Strangely, I can still burn a disk in XP, but when I insert a data or software disk of any kind it is not showing up and doesn't open. the drive boots up and I can hear it spinning, but comtents can't be viewed. I've tried the firmware update with no success.

  postie24 16:27 24 Jan 2007

Are you using nero,if yes click here

OldBlossom,

the drive works fine when in another PC both reading and writing to disk it just won't work in my PC anymore but it has worked very well up until mid Dec 2006

postie24,

Thanks for the link but its no help I'm affraid, although i do use Nero.

Thank you both for your time and thoughts

[email protected]

  postie24 16:44 24 Jan 2007

Have you tried clearing out the upper and lower filters in the registry?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best phone camera 2017

Stunning new film posters by Hattie Stewart, Joe Cruz & more

iPad Pro 10.5in (2017) review

28 astuces pour profiter au mieux de votre iPhone