Phantom Drive

  olyman 13:12 04 Apr 2012
Locked

I have my data located on a second internal HDD with the OS on another HDD. I backup my data and system on an external HDD using Macrium Reflect in two separate partitions. I decided to update my data backup. I had to delete the existing backup folder through lack of space (permanently as Recycle Bin was to small) I did a fresh backup of my Data disk to the external drive using Macrium. Afterwards when I tried to close my external drive via "safely remove hardware" it said that I couldn't as the drive was "currently in use" (I have recently had similar problems in deleting files with a similar response). As the drive was not in use I had a look at the HDDs in "Computer". I found that as well as the "D" drive there was an identical "I" drive shown. This "I" drive doesn't show in "disk management". I wonder if this phantom drive has something to do with the "currently in use" problem. If so how do I get rid of it? Shutting down and rebooting has no effect.

  northumbria61 13:23 04 Apr 2012

Take a look at Problem Solved by Frank D in this link and give it a try

enter link description here

The message "Currently in Use" really means just that - a file (any file) could still be open on that drive preventing it from closing.

  olyman 13:57 04 Apr 2012

I tried the FrankD solution but no joy. Troubleshooting didn't find anything. I wonder if putting links from items on the data disk into the libraries on the main disk might be a problem. I'll try removing the library links. I don't find this W7 library function of any use anyway.

  northumbria61 14:02 04 Apr 2012

I don't find this W7 library function of any use anyway. I tend to agree with you on that one - another one of Microsoft's "useless" functions.

  olyman 14:36 04 Apr 2012

I removed the library links which solved the problem, though only after a restart. No phantom drive or hardware removal problem any-more. I now suspect that the library link between disks had been responsible for previous occasional problems when I was unable to delete or rename photo files because the "file was in use". Time will tell. Thanks for the input.

  northumbria61 12:59 05 Apr 2012

Thanks for the feedback - pleased to hear problem solved.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

Alice Saey's mesmerising animation for Dutch singer Mark Lotterman

iPad Pro 10.5in (2017) review

Comment booster votre iPhone ?