Peripherals Won't Work Ubuntu 14.04

  SkyGuy98 00:26 25 Apr 2015

I am an avid Mac user, but have a couple of older windows PCs. I also have experience repairing computers. The computer I need help with is a HP Pavilion m9000. It used to have Windows Vista but I put Ubuntu 14.04 on it. It has worked since I bought it in 2009, but a couple of weeks ago, I tried to turn it on, and the tower booted, but no externals worked (I use a wireless mouse, plug-in keyboard, and HDMI/VGA monitor). I have opened the tower and cleaned inside, as well as looked for loose wires and other problems, but it still does not work. If I could get the keyboard and monitor to work long enough to boot to USB, I might be okay, but the keyboard does not do any input and the monitor does not receive a signal. What can I do to fix my computer?


  LastChip 02:33 25 Apr 2015

Are you saying, you cannot even access the BIOS with your Keyboard etc?

  LastChip 02:35 25 Apr 2015

Whoops, should have said, can't you access the BIOS with a wired Keyboard etc?

  SkyGuy98 05:01 25 Apr 2015

LastChip that is correct. I only use wired keyboards with that computer. It does not register any input, and I cannot see anything on the screen because my monitor says "No Input Signal". It does not work plugged into the VGA or HDMI of the graphics card or the integrated ports.

  LastChip 12:44 25 Apr 2015

It's almost certainly a hardware problem then.

It maybe it's the motherboard and/or the cpu, but you can only test that with a specialist card.

It could also be the power supply has lost one of the lines. But again, you need a specialist tester to find out.

If you've got a spare power supply knocking around, pop it in and try it. You don't need to bolt it in, just connect the relevant cables and try it.

I guess your monitor works with other machines, or haven't you checked that? It's worth checking, even though you're getting the "No Input Signal", because it could be a bad graphics cable between the computer and the monitor.

  SkyGuy98 19:36 25 Apr 2015

I have tried the monitor with other machines and it works fine. I can try changing the power supply. I'll reply when I have done that.

  LastChip 16:42 26 Apr 2015

This is just another avenue I thought about that may help you.

I don't know how familiar you are with electronics, but blown capacitors on the motherboard are a sure sign, it's either failed or almost failed.

If you've no idea what I'm talking about, do a Google search for blown capacitor images and you'll see how to identify them. The top bulged and stained is an instant give-away.

  rdave13 16:54 26 Apr 2015

As it's an old PC when was the last time you changed the CMOS battery? If it's not used regularly then the battery might be dead and in some cases can cause all sorts of problems.

  SkyGuy98 03:58 10 May 2015

Sorry is has been so long. I replaced the CMOS battery, and reset the CMOS memory again. I also checked for blown capacitors and do not see any. However, now I cannot even get the computer to turn on.

  LastChip 14:34 10 May 2015

So did you try a power supply?

You say you can't turn the computer on, can you be more specific? Are there any signs of power or not? Any fans running even for a second or two for example or is it just dead?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

These brilliant Lego posters show just what children's imaginations are capable of

Mac power user tips and hidden tricks

Comment réinitialiser votre PC, ordinateur portable ou tablette Windows ?