pendrive won't format

  Throbber 19:05 02 Nov 2009
Locked

I have a 32 Gb pendrive which used to work, but now won't format. I get the error message "Windows was unable to complete the format."
When I go into properties for the pendrive, it says that the File System is RAW.
Is this behind the problem, and is it fixable?
Running Windows XP Pro Service Pack 3.

  User-1229748 19:21 02 Nov 2009

from kioskea.net1. insert the pendrive
2. dont open or format it directly
3. right click on my computer and go to manage
4.in computer managment window click on disk managment option
5. right click on the removable disk (i,h....)
6. select format

  mooly 19:25 02 Nov 2009

Might be faulty but see,
click here

and Google,
click here

  Deekio 21:24 02 Nov 2009

smackheads posted the correct solution.

  mooly 17:28 03 Nov 2009

Did any of the solutions work :)

  Throbber 21:45 05 Nov 2009

Many thanks to all, but sadly none of the above has worked, even though in disc management it says the thing is healthy and shows 31.9 Gb. I fear I'll have to assume it's goosed. Unless anyone has a different thought?

  BRYNIT 22:02 05 Nov 2009

Have you tied the Pen drive on another computer, this will help determine if the Pen drive is faulty.

  Technotiger 22:02 05 Nov 2009

Try the first solution shown here, though I don't know if it will work, loads of people having the same problem, no one seems to have come up with a definite solution. So this is worth a try ...


click here

  Throbber 23:11 05 Nov 2009

Thanks again for all your help, but sadly still no joy. The pendrive LOOKS as if it is formatting right up to the last moment, and then it fails. Frustrating!

  Throbber 01:06 28 May 2010

Have given up and binned pendrive. Thanks for all your suggestions. I suppose components do fail sometimes!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

Stunning new film posters by Hattie Stewart, Joe Cruz & more

iPad Pro 10.5in (2017) review

Comment faire une capture d’écran sur un Mac ?