PClinuxOS2007 Internet connection issues

  smy13 12:22 30 Oct 2007
Locked

Hi I've been trying pclinuxos 2007 as a live CD but I can't get the Internet connection to work I've even tried setting it manually with my XP information but it's still no go I've been trying to set it up as as Ethernet connection as my PC connects to a router/modem via an Ethernet cable. I think this is the correct option
the connection is a Realtek RTL8139
and these are the setting I've been using

Physical Address:
IP Address: 10.0.0.3
Subnet Mask: 255.0.0.0
Default Gateway: 10.0.0.2
DHCP Server: 10.0.0.2
Lease Obtained: 30/10/2007 12:10:20
Lease Expires: 31/10/2007 12:10:20
DNS Server: 10.0.0.2
WINS Server:

any ideas

  smy13 15:15 30 Oct 2007

/\/\

  skidzy 15:39 30 Oct 2007

You are not alone Smy ?

Not exactly your issue,but some sound advice from the LOS experts and may help you out. click here

  smy13 19:06 30 Oct 2007

Thanks skidzy
i'll give it a read i'd like to get it sorted as pclinux seems more polished than Ubuntu and I want to take the leap from running live CD's

  LastChip 19:31 30 Oct 2007

should have no trouble at all with a Realtek 8139, one of the most common network interfaces.

click here for a run through of what everything means and although I wrote this for a wireless connection, just substitute the default Ethernet setting at the correct page and it's pretty much the same. Almost certainly, the default settings should see you through.

If you're having problems (not wishing to teach you to suck eggs or anything) but do make sure you're using a patch (straight through) cable and that it's connected to an "out" port on the router.

Truthfully, this should be a non-issue, which makes me think that just maybe, something else is wrong.

  smy13 22:39 30 Oct 2007

Thanks LastChip
I know the 8139's common and I can see the Module in PCLinuxOS. but I've just spent 3 hrs trying to get it to work. cable and every thing is OK as every thing works OK from windows (which I'm back in to catch up on this thread), thanks for the info anyway

  dms05 22:52 30 Oct 2007

I use PCLinux 2007 without a problem. Your IP and Gateway settings don't look anything like correct. In XP what do you get when you run ipconfig from cmd? You should get something like:
192.168.0.1 with a submask of 255.255.255.0 and a Gateway of 192.168.0.1. You should use these in PCLinux 2007.

However in PCLinux 2007 just chose auto DHCP and all this should be done automatically.

  smy13 23:08 30 Oct 2007

Hi dms05
running ipconfig from the command prompt i get :
Connection-specific DNS Suffix.:
IP Address.................... :10.0.0.3
Subnet Mask....................:255.0.0.0
Default Gateway................:10.0.0.2

Have chose Auto DHCP and got no where

thanxs

  smy13 23:27 30 Oct 2007

dms05

Just tried your settings and still no go I must be going wrong somewhere

  dms05 08:37 31 Oct 2007

smy13 - PCLinuxOS has a good forum where you will find many others using the OS click here and if you post under Network you may get specific help. Another place worth trying is click here in the Internet section. Try both.

Your 10.0.0.2 seems to be specific to Cisco routers (10.0.0.1 appears to be a reserved private address).

A quick Google suggests that with an IP address of 10.0.0.x you should be using a submask of 255.255.255.0 - if the submask doesn't tally with the IP address you won't get anything.

  dms05 08:39 31 Oct 2007

and take a look at click here which suggests the ethernet connection may be disabled in BIOS.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

See the work of famous artists playing with toys

iPad Pro 10.5in (2017) review

Comment faire une capture d’écran sur un Mac ?