PC works when wireless but not hard-wired

  old china 12:47 15 Mar 2006

I've a 3Com wireless 11g modem router and 2 PCs. My PC hardwired to the router gets erratic internet connection (sometimes fine, often can't find page) but if I unplug the ethernet cable and stick an usb wireless adaptor to the PC, everything's fine. Must also add that the LAN connection seems to have IP-addressing problems too. (I posted another thread in Absolute Beginners on 14 March before I got to this stage.) See link click here

Where does the problem lie? Any ideas much appreciated.

  Danoh 13:47 15 Mar 2006

It is highly unusual for the wired connection to be less reliable then your wireless connections.

From your other thread, you have logically narrowed down the variables.
And it does look like its your ethernet cable which is at fault. (they are very cheap e.g. at click here)

But your mention of IP addressing problems could be a contributory factor ~ although I would expect the wireless connections to be affected as well in that case.
Can you elaborate on those?

Are you setting the router to expect a dynamically assigned IP by your ISP? (most ISPs do that).

I must commend you on your clear thinking despite the pressure from teenagers' homework!

  dms05 14:42 15 Mar 2006

The SIS900 is the Network card in your PC. I have the same in one of my laptops and it works fine with D-Link WiFi.

From your extensive description of the problem, and the fact that the system did work correctly for a period of time, it would seem the 3Com has a problem. As others have said 'if it's faulty then Misco have a legal responsibility to put it right - and because it went wrong so soon you have the legal right to a refund and even if nothing was wrong you have the sameright(under the Distance Selling regulations you can return the goods within 7 days for ANY reason).

However it could just be the SIS900 Network card has developed a fault - did you use it before you added the 3Com?

Can you swap either the Network Cards or the whole PC to see if #2 PC works Ok when connected by LAN cable (if the cable worked initially it is unlikely but not impossible for it to be the problem).

  old china 12:07 16 Mar 2006

Thanks Danoh. Sorry for posting in this forum as well as the Absolute Beginners, I thought it might just catch a few more ideas.
click here

Yes, I shall find a friend who has a LAN set-up PC and test my cable using her system, rather than just buying a new cable. Then I can actually say whether my cable is faulty or not.

I shall investigate further the IP addressing problem.

I just checked my router config., under Internet Setting > DNS Setting, the 'Automatic from ISP' box is checked. Is that the same as 'dynamically assigned by my ISP'?

  Danoh 12:35 16 Mar 2006

Yes, 'Automatic from ISP' means your IP is assigned dynamically by your ISP.

Your router's DHCP server should automatically assign but if the DHCP server has been disabled via the router's config page, then it would set as your other thread has mentioned.

Try removing power from your ADSL modem (after switching your PCs off), wait 5 minutes and power it back on again.
After it settles down (say a few minutes more), switch on your desktop PC, then your wireless PC.

If things still do not work, check if your SIS900 PCI Ethernet adapter is working by the lack of yellow exclamation or question marks in Device Manager;
Start> Control Panel> System> Hardware ~ Device Manager

Until you can get round to testing your Ethernet cable on your friends system.
BTW, I presume its the same Ethernet cable that came with the router?
Normal Ethernet cables, called patch cables, can not easily be distinguished from "cross over" Ethernet cables with have 2 wires connected differently.

No worries about double postings :-)

  old china 13:25 16 Mar 2006

Thanks. I shall see if I have the same problem using PC#2 instead. Also, I shall try to get a refund. Wish me luck!

  old china 14:27 16 Mar 2006

The DHCP server in the router is certainly not disabled, it is IP-addressing the usb adaptor correctly, and IP-addressing the LAN on my PC (sometimes!) correctly as well. However, when the IP address is correct, I still get 'limited or no connectivity' from LAN.

Yes, the cable comes with the router kit, it says 'category 5'. I did wonder if it was 'cross over' type (heard of them, but don't know how to identify, do you hold the both end side by side, or straighten the cable when you compare the colours of the wires?)

From other advice on the forum(thanks dms05), I am now trying to press Misco to give me a refund; yesterday was my 7th day, time is running out (indeed run out, but I stressed that Misco gave me wrong information a few days ago).

Already checked my ethernet adaptor in device manager, normal icon (no yellow exclamation mark); went into the properties, everything seems fine. I thought of uninstalling the adaptor, but no sure if it will get reinstalled automatically when I restart the PC.

I think my next step is to try the system using a different PC, because if the problem persists, then the culprit is with the router or the cable, both are from the kit I just bought.

  old china 15:46 16 Mar 2006

Just to add that I don't have a network card in my PC. (Actually the router manual said 'disable the network card if there's one in the PC.) Also, the SiS900 ethernet adaptor seems fine, see my above post.

  old china 14:32 17 Mar 2006

see link click here

  old china 14:33 17 Mar 2006

see link click here

  old china 16:19 17 Mar 2006

Sorry, folks. I've ticked 'resolved' box twice already, but the thread still shows unresolved. Third time lucky? :)

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

Halloween Photoshop & Illustrator tutorials: 20 step-by-step guides to creating spook-tacular…

iPhone X news: Release date, price, new features & specs

Comment créer, modifier et réinitialiser un compte Apple ?