PC won't start - "Windows root file missing "

  musicbassman 06:12 28 Sep 2006
Locked

Hello folks
When booting my home computer(XP)nothing happens - and I get the message "Windows cannot start because windows root>\system32\hal.dll is missing or corrupted. Please replace this file"
Suggestions please? I have the XP OS disc but not sure how to solve this.
Thanks.

  Mark5001 07:11 28 Sep 2006

click here

This may help you

  musicbassman 07:55 28 Sep 2006

Thanks Mark, but didn't really understand this, and couldn't find the link off that article.
Can I use the recovery console for this?

  musicbassman 11:28 28 Sep 2006

I found this article click here
This is fine up to stage 9 where I type 'bootcfg /rebuild'. According to this article my boot.ini file should repair itself, but I get the following after I have typed bootcfg /rebuild :

Total identified windows installs: 1
Add installation to boot list <Yes/No/All>
Enter load identifier
Enter load options

I don't know how to respond to the Yes/No/All options - I've tried moving the arrow cursors, tried entering Y, and tried entering 1.
Also I don't know how to respond to the other two queries - the load identifier and load options.

Can anyone help please?

  musicbassman 19:16 28 Sep 2006

Still hoping for someone to advise on this.........

  Mark5001 20:21 28 Sep 2006

Insert the Windows XP bootable CD into the computer.
When prompted to press any key to boot from the CD, press any key.
Once in the Windows XP setup menu press the "R" key to repair Windows.
Log into your Windows installation by pressing the "1" key and pressing enter.
You may then be prompted for your administrator password, enter the password.
In the example below we are copying the file from the CD-ROM drive letter "E". This letter may be different on your computer.

copy e:\i386\ntldr c:\Windows\System32

Accept the overwrite prompt and reboot.

  Mark5001 20:22 28 Sep 2006

Sorry got lost in the last post. Type
copy e:\i386\hal.dll c:\Windows\System32
or
copy e:\i386\hal c:\Windows\System32

  musicbassman 21:02 28 Sep 2006

I went on the web this evening on my work PC and found some more info about these problems. I did use the bootcfg/rebuild command in the Recovery Console, and managed to find out what to enter about the Load identifier and Load options. All seems OK now. Thanks again.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Microsoft Surface Book 2 hands-on review – bigger and 5x faster

Best kids apps for iPhone & iPad

Que faire si son iPhone ou iPad est tombé dans de l'eau ?