PC won't start unless I unplug USB hub

  Agent Smith 19:21 04 Jan 2006
Locked

Hi folks, it's been a while.

I'm running XP Home. I've just bought a 7 port USB 2 hub from Ebuyer click here

This is a powered hub and will also work in passive mode. When I tried to start up the PC I notice that the HDD busy light is on and the PC will not boot. If I disconnect the power to the hub the PC boots up as normal.

This never happened with my Belkin 7 port USB 1 hub.

Any thoughts? I can't send the hub back as I've already dumped the packaging.

Thanks, Bob.

  Fruit Bat /\0/\ 19:41 04 Jan 2006

How old is the PC? fairly new?

Bios may be trying to boot an Op system from USB.

disable USB boot device in BIOS.

  Forum Editor 19:44 04 Jan 2006

if you start with the hub off and turn it on once Windows has loaded?

  Agent Smith 19:55 04 Jan 2006

PC is newish AMD XP3200+ 512 ram. ASUS MoBo

Once windows has started and power supplied to the hub it's OK.

As I said AOK with the hub in passive mode

  woodchip 19:57 04 Jan 2006

Check the BIOS on what USB's are turned on

  woodchip 20:05 04 Jan 2006

If Legacy support is turned on, disable it save settings and exit BIOS and retry comp

  LivEviL 20:36 04 Jan 2006

its coz the order of boot has usb device before harddrive just change it in the bios!

  GuZ><0r 20:39 04 Jan 2006

I am guessing that Agent Smith is now LivEvil. Am I right, or just not reading correctly.

  Agent Smith 20:49 04 Jan 2006

No I am Agent Smith and no one else, sorry to disappoint. I've been a forum member for years, just not been on in a while.

  Agent Smith 20:55 04 Jan 2006

LilEvil if your theory is right how is it that my old USB 1 hub never caused the same problem?

One thing I've noticed is that while the hub is powered and connected via A-B lead then power is supplied to my ADSL modem which is plugged directly into a USB port at the PC.

As soon as the PC is after POST and I power up the hub it will work.

I'm trying to get into BIOS but using alt + F2 as per instructions all I get is do I want to boot in Safe Mode.

  woodchip 10:24 05 Jan 2006

try tapping the Del key as you boot

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best phone camera 2017

Stunning new film posters by Hattie Stewart, Joe Cruz & more

iPad Pro 10.5in (2017) review

28 astuces pour profiter au mieux de votre iPhone