PC won't recognise drives

  ukzz4iroc 10:06 29 Nov 2004

It is my father in laws Dell PC. It's a P3 with Windowns XP Pro. It doesn't pick up the fact that there is a DVD and CDRW connected to it. It used to be fine but not even when I try and update drivers etc, it says there was a problem. I have tried installing another CD just so I eliminate the drives being at fault but still no good. I feel I need to re-install Windows but of course can't whilst I can't run the drives.

What can I do? Is there anything at download.com for example that I can run?

Any help much appreciated.


  BurrWalnut 10:00 29 Nov 2004

Try this if the optical drives are not appearing in My Computer or Device Manager. This is sometimes caused by the removal of Roxio software. Run regedit and navigate to registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}. Highlight it and in the right pane, find the Upperfilters and Lowerfilters values. Highlight each one in turn, right click and delete them. Close regedit and restart the computer. If if doubt make a restore point before making changes.

  BurrWalnut 10:03 29 Nov 2004

There appears to be a little bug here as my reply is listed, and timed, before the original question.

  ukzz4iroc 10:15 29 Nov 2004

I did remove Roxio some time ago so sounds like you have the right answer! It seems a little techy for me though. Is regedit DOS? How do I run it?

Thanks again

  ukzz4iroc 10:16 29 Nov 2004

Drives are recognised in BIOS

  Gongoozler 10:17 29 Nov 2004

Have you checked in BIOS to see if the drives are recognised there?

  Gongoozler 11:48 29 Nov 2004

I think that as long as your drives are recognised in BIOS, and set to be the first boot device, you should be able to reinstall Windows.

  BurrWalnut 14:26 29 Nov 2004

1. Create a restore point, Start, All Programs, Accessories, System Tools, System Restore, Create a restore point and give it a meaningful name.

2. Start, Run then type in regedit and press enter.

3. On the left pane keep pressing the plus signs until you get to the key above.

4. When the Upper... and Lower... appear in the right pane, just right click each of them and delete, etc. as my post above.

5. If the keys are not there, it is a differnt problem.

6. If you have finger problems and mess it up (very unlikely) go to System Restore and restore from the point you made in 1.) above.

  ukzz4iroc 10:05 30 Nov 2004

BurrWalnut- thank you so much- did it last night and it's fine now!

Really appreciate you guys taking the time out to help me out on something I don't think I ever would have solved.

Happy Christmas!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment utiliser Live Photos ?