pc won't connect to the internet through router

  dirt 20:16 31 Aug 2006
Locked

the kids pc downstairs is hooked up using a 802.11g wireless lan mini usb adapter which then connects to a wireless-g adsl router upstairs.
the kids pc is win me.
the installed software (zydas ieee 802.11g) works fine and the correct lights are lit on both the adapter and the router.
however the pc won't connect to the internet.
ie just keeps flickering as if trying to connect but it can't and eventually gives up.
the router is dhcp enabled.
i don't get why they are connected but the pc can't use the internet.

i have tesco broadband adsl

help!!
any ideas?

cheers

dirt

  Devil Fish 22:03 31 Aug 2006

the computer that wont connect

1 does it have a firewall running

2 go to control panel network connection right click connection then click status then support

is it giving you an ip address subnet mask and
default gateway

should look something like this


Address type assigned by DHCP

IP Address 192.168.1.100

sub Net mask 255.255.255.0

Default Gateway 192.168.1.1

your ip's may be different

  dirt 19:10 01 Sep 2006

the pc doesn't have a firewall..not that i'm aware of. it did have some security software on ther but i got rid cause the kids mess it up all the time!
can't do step 2 like that...this is win me.
the network icon in control panel gives me network settings.
one is tcp/ip zydas usb. the other tcp/ip is for the other onboard network adaptor which i have now disabled just incase but it's made no difference.
if i type winipcfg in command prompt i get this:

ip address 169.254.126.207
subnet mask 255.255.0.0

no default gateway

not sure but isn't the 169 address assigned by windows when the dhcp server isn't working?

in the ip configuration window the release button does nothing. the renew button brings up the sand timer for about 2 mins then comes up with this error :- dhcp server unavailable.
if you press ok nothing happens.
the release all button does nothing and the renew all button brings up the same error message as the renew button with the same outcome.....nothing.

  dirt 19:10 01 Sep 2006

i am pretty sure the router is set correctly as i have a pc upstairs that is hooked up to the router through a network cable. this works fine and is assigned the correct ip address and default gateway etc.
i have tried the wireless adapter on this pc (which is xp by the way and probably explains why there are no problems!!) and it works fine with no configuration at all.

i tried to mess with the tcp/ip settings for the usb adapter and told it to use the correct default gateway that the router uses which is :- 10.0.0.2 but that made no difference.
there are lots of other settings under tcp/ip like g-mode or something.not touching that.....pc might blow up.
this is as much info as i can sort out at the mo
please get back to me if you have any ideas or things i can try.
i have been at work all week, am knackered and have beers waiting.
however, the kids are moaning for the net and i promise not to start enjoying myself until this is sorted......it's friday night, 19:00 and i'm waiting for your help.
please take pitty on me!!
lol

cheers once again

dirt

  dirt 21:09 02 Sep 2006

ok i've solved the problem
i removed all protocols listed in network settings leaving only these:
client for microsoft networks
file and print sharing for microsoft networks
tcp/ip
zd1211 ieee 802.11 b+g usb
(this is for the usb wireless network adapter and existed before but was tcp/ip zd1211 ieee etc)
the other step i took were to check the properties for the usb adapter. in the properties window under the configuration tab there were properties on the left, with a big list, and the values of those properties on the right giving you the option to disable, enable etc. one of those properties was USE G MODE IN USB 1.1 which was disabled by default. the network adapter is for both b+g (whatever that is) so the g in it along with the usb made me want to change that setting...just made sense.......i think.
ruddy thing only worked you know!!!!!!
i went back and undid my steps to confirm that this was the right thing then redid everything again and BINGO!!!!! i have a large grin on my face and the kids are back on the net and off my back.

cheers all

dirt

  dirt 21:10 02 Sep 2006

ok i've solved the problem
i removed all protocols listed in network settings leaving only these:
client for microsoft networks
file and print sharing for microsoft networks
tcp/ip
zd1211 ieee 802.11 b+g usb
(this is for the usb wireless network adapter and existed before but was tcp/ip zd1211 ieee etc)
the other step i took were to check the properties for the usb adapter. in the properties window under the configuration tab there were properties on the left, with a big list, and the values of those properties on the right giving you the option to disable, enable etc. one of those properties was USE G MODE IN USB 1.1 which was disabled by default. the network adapter is for both b+g (whatever that is) so the g in it along with the usb made me want to change that setting...just made sense.......i think.
ruddy thing only worked you know!!!!!!
i went back and undid my steps to confirm that this was the right thing then redid everything again and BINGO!!!!! i have a large grin on my face and the kids are back on the net and off my back.

thanks for your help devil fish

hope this can help some out of the same problem

cheers all

dirt

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best phone camera 2017

Stunning new film posters by Hattie Stewart, Joe Cruz & more

iPad Pro 10.5in (2017) review

28 astuces pour profiter au mieux de votre iPhone