PC won't boot when external USB drive is connected

  Throbber 11:27 17 Aug 2008
Locked

I have an external USB hard drive. When this is connected, my PC won't boot. If I disconnect the drive, the PC boots just fine. If I then connect the external drive, it works just fine too. Any idea why this happens, and if it can be fixed?

  johndrew 11:41 17 Aug 2008

The PC is looking at the external HD as the boot device. Go into BIOS and check the order in which the PC looks for the device (drive) to boot from and ensure your C: drive is the first.

  Quiller. 11:41 17 Aug 2008

Check the boot sequence in the bios. Make sure your internal hard drive is listed before usb or other drives.

  jack 11:46 17 Aug 2008

Consider- The external drive- Where does it get it power from?
If it is USB power then exessive power drain could be a cause.
The remedy is to power it externally with a 'Power Brick'

  Throbber 12:29 17 Aug 2008

Thanks guys, boot sequence error sounds most likely. How do I access the BIOS to change this?

  jack 13:54 17 Aug 2008

Shut the machine down
restart and watch for a message in the POST sequence[that is the black and white bit frore Windoze starts]
As message that says to access BIOS press delete
[mostly it is delete you press but can vary]
A Basic 3 colour windows opens
This gives you a series of option the you access with the up down arrows and enter - you need 'Advanced'- look down the list for Hard Disk Boot sequence and using the page up/down key cycle through them so that 'C' drive come up- then press F10 to exit and press yes when asked -
Take your time and read everything twice.
If you have the Motherboard handbook have a read up.

Having said all that I do not think USB is a start option normally unless your BIOS is more up todate than mine.
You will will see.

  Quiller. 14:13 17 Aug 2008

Do you know the make and model of your motherboard?

As per jack. Also some motherboards, asus etc have a heading for boot. The setting would then be under there. You may have to look for a setting that says boot from another or external device.

This may or may not be under the boot section. Thats why it would be helpfull to have the motherboard details to check the exact setting.

Also do not alter anything else in the bios. If you alter a wrong value you could make the machine un-bootable or even damage the components in the computer.

  Throbber 14:36 17 Aug 2008

Motherboard is Micro-Star International MS-7222.
BIOS is Phoenix Technologies Version 6.00 PG. Is this helpful?

  Fruit Bat /\0/\ 14:40 17 Aug 2008

The usual message ie "press ??? to enter setup"

where ??? is usually esc , del, F1 or F2

  Throbber 14:53 17 Aug 2008

I'm struggling to access BIOS as there is only a very momentary POST sequence. Is it possible to slow it down?

  Quiller. 15:01 17 Aug 2008

Yes that is great.

restart the computer and keep tapping the delete key as soon as you switch on. If the logo gets in the way, press the tab key and then keep tapping the delete key.

When the bios page loads go to the advanced bios features section.

scroll down to boot sequence and set the boot from other device to no. Set the C drive to first device and then press the F10 key on the keyboard.

This will save the settings and reboot the computer with the new values.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

AMD Ryzen news - release date, UK price, features and specifications

The 12 best apps for drawing and painting on your iPad

Mac power user tips and hidden tricks

Comment faire des captures d’écran sous Windows 10 ?