Pc wont boot, blank screen

  User-7F6FF770-BD4F-47E5-9BA55A2F8E7FDFF9 16:35 16 Feb 2007
Locked

Having trouble with my PC after a car journey.

I took the machine to work and back in the car a couple of days ago and it hasnt worked since.

Its a 4 month old Zoostorm edge specs as follows :-

Intel Core 2 Duo E6700 2.67GHz, 1066MHz, Processor

500GB WD Caviar SE16 SATA ATA300 Hard Drive

2GB DDR2 667 Memory

512MB PCI-Express NVidia GeForce 7900GTX Graphics Card

Creative Labs SoundBlaster X-Fi Xtreme Music PCI Soundcard

ECS P965T-A Motherboard

Wireless LAN PCI Network Adapter 54Mbps

Wired Gigabit LAN

16x DVDRW Dual Format Double Layer Drive

16 x DVD-ROM

52 in 1 Flash Card Drive

When I power up the pc the main power light comes on and stays on, the HD light goes on for a few seconds during which Im pretty sure I hear the drive chattering as if accessing.

Thats it however, no bleeps, no video output, unresponsive keyboard and mouse (Keyboard caps and num lock lights sem to all be lit up slightly, can just see it with the naked eye)

Ive checked and double checked cable including internal power supplies and data cables. havent reseated any cards as they all seem tight and are screwed to the casing.

Im thinking no bleeps means a messed up motherbooard somehow ?

Anything I can try would be appreciated before I return the machine under warranty - Cant bear the thought of god knows how long without it :(

Thanks in advance

  Fruit Bat /\0/\ 16:56 16 Feb 2007

I took the machine to work and back in the car a couple of days ago and it hasnt worked since.

Thats it however, no bleeps, no video output.

Sounds like bad connection to monitor, check monitor leads for bent pins and remove and refit the graphics card may have jarred loose.

  SANTOS7 16:57 16 Feb 2007

First thing to check is your PSU, a fair test would be to replace it to eliminate it being a goner, if the problem persists you may have a loose component on your MOBO, they may look secure but i think you are going to have to make sure they are all firmly in there place..

  We5ty 17:04 16 Feb 2007

Yes agree, probably an internal card has worked loose while it was bumping around. Most likely graphics card.

Remove and refit all cards, including RAM modules.

If that doesn't do the trick then you may well have a hardware issue!

But bet it's the graphics card, cos they need to be initialised before POST - usually your graphics card displays something on the screen prior to the full POST routine.
HTH

Thanks for the replies, gives me some things to try later.

I didnt know that POST was after GPU initialisation. I thought POST was the first thing to happen whatever so that looks like the first thing to try although its screwed in firmly so Im not that hopeful.

With regard to the PSU, the lights are on so it cant have failed can it ?

Cant get to the machine until tommorow so any more hints will be appreciated in the meantime.

Thanks

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

Is this the future of VR and AR?

Best iPad buying guide 2017

Comment regarder le Bureau des L├ęgendes en ligne ?