PC Tools Firewall Plus

  johndrew 15:46 15 Jul 2010
Locked

A short while ago I posted for help with a replacement firewall and chose that supplied by PC Tools click here

I have noticed the Windows Firewall is fully disabled; it cannot be started as the Internet Connection Sharing (ICS) service cannot be started.

Can any user, or anyone who knows, advise if installation of the PC Tools firewall automatically inhibits the function of the Windows Firewall?

Many thanks in anticipation.

  rdave13 16:34 15 Jul 2010

PC T does disable Win Firewall. Though ICS is started in services and on auto for me. If you right click PCT in system tray and click exit, click ok on warning then start win firewall, go to services.msc and scroll down to Windows/firewall internet connection sharing and select automatic and start.
Re-establish PCT and check Win firewall disabled and ICS is running.

  johndrew 16:59 15 Jul 2010

Interesting.

I closed PC Tools Firewall and got the 'red shield' warning that I was not protected.

I went to services.msc and the entry Windows Firewall/internet connection sharing and it is on Automatic.

I tried to start Windows Firewall and got the message that ICS was not running I attempted to start ICS and got the 'wait whilst ...' message and then the message that 'Windows could not start ICS'.

I then tried Control Panel/Firewall but again was unable to get the 'on/off' option window as ICS could not be started.

PC Tools Firewall started when selected in 'All Programs'.

Looks as if something is broken but I have no idea what or how to fix it. Anyone have any suggestions?

  rdave13 17:10 15 Jul 2010

Try a reboot and see if the service has started.

  johndrew 11:31 16 Jul 2010

Well I tried a reboot - no effect.

I also ran sfc /scannow in case there were any broken files but this has had no effect.

I have noticed that all my Restore points up to yesterday have disappeared - no idea why. The only one remaining is for a Defender update yesterday. Could the sfc /scannow have removed them?

I also examined the Event Log but can find nothing that indicates ICS being stopped. The only service indicated as an error that I don`t recognise is DCOM but that shows up consistently to the earliest record in the log on 5 July.

Windows Firewall was definitely functional up to the installation of PC Tools Firewall on 11 July as I was using it.

Has anyone any ideas, please?

  rdave13 12:32 16 Jul 2010

Have a look at this solution; click here

  johndrew 14:34 16 Jul 2010

Thanks for coming back.

I think I may have the answer in a round about way even though I`m using PC Tools and not OneCare.

I searched MS and found click here which I thought may be the cause. Both solutions failed as I still couldn`t get Windows Firewall settings box to appear but still got the ICS message.

I also got an "Error 158" message which led me to click here which indicated the service was available as Windows Firewall/Internet Connection Service appeared in the list. I double clicked as advertised and found it disabled so I enabled it and rebooted.
I still couldn`t run it but got "error: 2" which led me to click here.

I now think that either I have a corrupt file as shown in the link above or it is PC Tools firewall that is stopping the service completely. However having run sfc /scannow - which should have repaired everything - the only way I can check is to uninstall PC Tools firewall.

Before I do this, will you confirm that you can open the Windows Firwall selection window where it can be turned on & off, please? Or do you get a failure message when you try to start it?

Many thanks.

  johndrew 14:35 16 Jul 2010

"Error 158" should be "Error 1058"

  rdave13 14:41 16 Jul 2010

I can start/stop Win firewall from security centre even with PC Tools running. My link did not help with merging the reg key etc.?
It could have happened when you installed/uninstalled those different firewalls when you were trialling them.

  johndrew 16:44 16 Jul 2010

The solution in your link is the same as that in the first of my links above from MS; unfortunately it failed as I said.

It is possible that one of the other firewalls caused the problem. I have one other option before I really hit rock bottom. I have an ERUNT Registry backup from a couple of days before that I can install and try. Hopefully this will work without destroying other updates and such - it has to be worth a go and I shall make certain I have a backup of the current Registry settings just in case.

Wish me luck.

  rdave13 17:46 16 Jul 2010

Any luck with the registry backup?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Microsoft Surface Book 2 hands-on review – bigger and 5x faster

Best kids apps for iPhone & iPad

Que faire si son iPhone ou iPad est tombé dans de l'eau ?