PC -> Printer Error: Won't Print Accurately

  Kleric 09:36 23 Jun 2005


I am having an immense amount of trouble trying to get an Epson 830u printer to print correctly. It has been installed (USB1) on my parents pc (Win ME) for a quite a while and has worked fine. Recently over the last couple of weeks though it has decided to stop printing properly. It now prints out a few lines of text, then prints some more over the top, then scrolls through a couple of blank sheets, then prints a couple more lines of text. The same happens if u try and print a photo. It's not pretty. The PC itself has not been changed, nothing newly installed, downloaded or attached or anything like that.

So I went through all the usual maintainence utilities on the printer software. None solved the problem. I went onto the Epson website and got the latest driver and status monitor software. Nothing solved the problem. I changed the ink cartridges to official Epson ones. Didn't solve the problem. I used a different USB connection lead. Didn't solve the problem. I changed the paper it was printing on. Didn't solve the problem. Every document I tried to print looked fine on the 'pre-print' print preview, but then prints completely messed-up. I began to think the printer was interpreting the data it was receiving from the pc wrongly.

Then . . . I unplugged the printer from the pc, and plugged it into a laptop. I loaded a text document on the laptop and printed it. Voila, it printed fine.

This changed my view of the problem again. The USB cable and printer work fine. It has to be a problem with the pc sending the data from the Word document (or whatever the print source) to the USB socket.

Both USB ports work fine, I tried other devices in them and they worked ok, just the printer that isn't working

How I fix that I've no idea

Any ideas would be very gratefully recieved

and thanks for bothering to read all this


  wee eddie 10:18 23 Jun 2005

Windows Printing system or Epson's own Software.

There may be a repair function for Windows as there is for M$ Office.

  €dstowe 10:39 23 Jun 2005

The faults you describe seem very much like corrupt drivers. You say you have updated the software but, did you remove the old software before re-installing and did you install EXACTLY to the letter of the instructions given. Even if you did, it would do no harm to have another go.

  Kleric 10:56 23 Jun 2005

thanks for the replies guys :-)

Nope, there's no Epson print software available/installed.

It's just installed through it's own driver and an "Epson status monitor" application

Yes I did remove the old installation before I reinstalled. I have reinstalled several times, all to no avail :-(

  €dstowe 13:54 23 Jun 2005

How did you remove the old installation? The "correct" way is via Printers and Faxes on the Start menu or Control Panel. Do not remove from Add/Remove Programs.

This may be the way you have done it. If so, I'm stuck!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Microsoft Surface Book 2 hands-on review – bigger and 5x faster

Best kids apps for iPhone & iPad

Que faire si son iPhone ou iPad est tombé dans de l'eau ?