PC Cannot connect to Netgear DG834PN Modem Router

  bazza2 09:56 14 Jan 2007

I have a rather old Win 98se desktop computer, and use virgin.net as my ADSL broadband provider.
When I subscribed to broadband I was sent a Speedtouch 330 USB modem, which has been working fine.

I have just bought the above modem, so that I can also use my laptop wirelessly.
As my desktop did not have an ethernet card I purchased a Belkin one, which seems to have installed successfully.

I have plugged an RJ45 between my desktop and the Netgear and, without connecting to the internet, tried to connect to the Modem using click here (as per the instructions).
But my computer cannot see it.
I cannot ping it either "host unreachable".

The instructions say that I should be using DHCP.
In the TCP/IP properties, under WINS configuration it says "Use DHCP for WINS resolution".
Is that all I need to have selected to ensure that DHCP is set??

When I run a winipcfg it says:


subnet mask

DHCP server

Why can I not see the modem??


  bazza2 10:01 14 Jan 2007

Sorry, this forum has tried to be clever with my text, and changed an IP address to a link.

In the above message, the "click here" should be the IP address if the Netgear which is http: // 192 . 168 . 0 . 1 (without the spaces).

  brundle 10:07 14 Jan 2007

Switch everything off, switch router on, wait a minute or so, switch PC on - if you don't see the `network cable is disconnected` warning your PC is connected OK to the router, try the 192 168 0 1 again, or IPConfig. The DHCP setting you mention is for Windows Networking, as long as you haven't had to manually assign your PC an IP address in TCP/IP properties DHCP is set up properly. The router should assign your computer an IP address on its own, probably 192 168 0 2 at first.

  bazza2 10:20 14 Jan 2007

I am not a networking expert, but I believe the 'physical' connection is working as the green light on the ethernet card is on, and the port number is lit on the front of the netgear, indicating that a cable is connected.
It just doesn't appear to be assigning an IP address to my computer.
I will need to have another go later, I have had to unplug everything to enable me to post this question (using my trusty old Speedtouch modem).

When does the modem assign an IP address to my computer, when I have connected to it using the IP address, or as soon as I switch both devices on?

  Stuartli 10:44 14 Jan 2007

Have you Enabled LAN in the Bios and, if necessary, install LAN drivers?

  bazza2 21:05 14 Jan 2007

I haven't done either of the above .... how do I check??

  bazza2 22:34 14 Jan 2007

I have just been looking through my internet options and noticed that under the LAN settings it says "Automatically Detect Settings".
So I assume the LAN 'stuff' is already installed (a big assumption I know).

Also I have noticed that when I run a winipcfg, the dropdown box only has an entry for 'PPP Adapter'.
Should it say 'LAN' or something else in there?

  bazza2 15:58 15 Jan 2007

I've finally managed to fix this.

My entry in Control Panel > Network which is called TCP/IP only related to my dial-up adapter.
My ethernet card was not using TCP/IP.
In 'Network' I selected 'Add' and selected 'Microsoft' > 'TCP/IP', pointed it to my CD drive with my Win98se disk in it.
Hey presto! A new entry for TCP/IP for my Belkin ethernet card.
After restarting windows I am now able to 'see' my modem/router and connect to the internet.

  bazza2 15:58 15 Jan 2007

Closing thread

  bazza2 15:59 15 Jan 2007

I'll try closing it again !!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

The Evil Within 2 review-in-progress

InVision Studio takes on Adobe XD and Sketch

Camera tips to take better iPhone photos

Comment transformer un iPhone en borne Wi-Fi ?