Partition & format 80GB hard drive

  mgmcc 22:59 09 Mar 2006

I'm tearing my hair out here trying to partition and format an 80GB Hitachi hard drive. I want to create two 40GB FAT32 partitions and then mount the drive in an external enclosure.

The drive is currently installed in the PC as Primary Master. Booting with a Win 98SE floppy only lets me create a partition of 13999MB (14GB). If I boot with a Windows XP installation CD, that only finds available space in which to create a partition of 4GB.

If I install the drive in the USB 2.0 enclosure and plug it in, XP's Disk Management sees the full 80GB of "Unallocated Space", but doesn't give me the option to create a partition. (The external housing's instructions do say the drive must be partitioned/formatted before installing.)

Am I missing something?

  terryf 23:07 09 Mar 2006

Look at click here, it is a doddle to use

  Fruit Bat /\0/\ 23:08 09 Mar 2006

attach as slave in your Xp system and use disk management to partion and format.

  Harpur 23:09 09 Mar 2006

first of all why fat 32 when ntfs is a better file system? secondly as far as i have experienced xp probably lets you format in ntfs.

  gudgulf 23:18 09 Mar 2006

What is the setup of the pc you are trying to do the formatting with?....You don't mention trying to partition the drive from within Windows with the 80GB drive as a slave fitted within the pc rather than in the external housing.

Another option is to use a Boot/Partition manager.

If you use the Yellow envelope and give me your email address I'll send you the files to create an Acronis boot disc (floppy) which should let you format/partition your drive as you wish.

  woodchip 23:33 09 Mar 2006

Firstly NTFS is no good if you want to use it on multiple systems that Have Fat32 or NTFS. With Fat32 it will be recognized by NTFS, but a Fat32 System cannot see NTFS partitions

  mgmcc 23:35 09 Mar 2006

I'm fairly certain now that the drive is faulty. I let FDISK create a Primary DOS partition of 14GB and after rebooting and checking the partition structure, there was no partition created.

The next time I rebooted, the PC hung on the BIOS listing having detected the hard drive but not my two DVD drives.

I'm not a novice and I'm not going to waste any more time on it - the drive's going back.

  ed-0 06:54 10 Mar 2006

You may be using the old type of fdisk off a 98se disk. These can be limmited to 64Gb, which would just leave the remainder visible, around 14Gb. click here=

It may be worth trying this fdisk 1.2.1 click here, works upto 128Gb before you send the drive back.

Although I agree that something doesn't seem right, it may be worth the time to run it.

  mgmcc 09:42 10 Mar 2006

<<< You may be using the old type of fdisk off a 98se disk >>>

Bingo! Absolutely "spot on". The 98SE FDISK was hiding 64GB and only displaying the excess.

I ran the 1.2.1 version you suggested and have now partitioned the drive into 40GB/40GB, formatted the two partitions, installed the drive into the external USB 2.0 housing and it's working. Many thanks.

  ed-0 10:21 10 Mar 2006

No problems M8.

Pleased it worked.;-)

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

Halloween Photoshop & Illustrator tutorials: 20 step-by-step guides to creating spook-tacular…

iPhone X news: Release date, price, new features & specs

Comment créer, modifier et réinitialiser un compte Apple ?