Parallel to USB printer cable won't install

  CLONNEN 13:25 11 Jun 2008

Trying to connect a Epson Stylus Color 480 parallel printer to a Vista laptop with a Parallel to USB adaptor cable.

Cable came with a disc containing drivers for Win 98 and ME only. The instructions say that XP and Vista systems should install the driver automatically as its built into Windows somewhere (doesn't tell me what the driver file is called so don't know what I am supposed to be looking for).

Have tried installing the cable first then the Epson parallel driver but nothing prints.

Also tried installing Epson driver first and then plugging in the cable but still nothing prints.

The Epson printer Properties page has a Ports tab but none of the entries mention USB at all. There's LPT ports and COM ports on the list.

  ambra4 15:20 11 Jun 2008

Just connect the printer via the adapter and load the printer driver

If requested a printer port select LPT 1

  woodchip 15:23 11 Jun 2008

did the add new hardware wizard pop up when you turned the printer on? If it did what did you click on the wizard? as you should choose let windows find a driver

  CLONNEN 17:01 11 Jun 2008

When we plug in the USB end of the cable to the laptop a message bubble appears in the System tray saying Detected new device Installing etc.

After a while a message bubble saying Your device has installed successfully appears. But it is then immediately followed by another message bubble saying that the device may not work properly.

The Device Manager states Unknown Device in the USB section and when we look at the Properties it says there is no driver currently installed for this device.

  Strawballs 17:04 11 Jun 2008

The first message is proberbly for the cable and the second because the printer drivers need installing, if you can get drivers for a printer that old for Vista

  Marko797 17:09 11 Jun 2008

going to the Epson site and dl driver from their support? Might be worth a shot as ur struggling.

click here

  CLONNEN 17:19 11 Jun 2008

Already got the latest Epson driver - we have been using it for several years on our dekstop computer via an ordinary parallel port.

But we now have a Network printer for heavy duty printing and want to use up the Epson cartridges we have left on the kids laptop as the Epson is quite good enough for homework. But the laptop doesn't have a parallel port so this connecting via USB is all new to me and the instructions with the cable are rubbish.

1. one point connects to the DB36 port of combing printer,and another point connects to the USB port of computer.
2. please turn on the printers’s power and insert this into the USB port.The WINDOWS SYSTEM will inform that :the computer has found a new hardware.
3. To the WINDOWS 2000/XP system, system will automatically find and recognize the driver, then inform you that it has found the printer and the automatical setting up will go on immediately.
4. To the WINDOWS ME, it needs to direct to the catelogue of DRIVER/WIN98 and set up the driver of printer’s combing port.The computer will inform that it has found the printer and will set up the compatible driver immediately.
1. You should use the right buttom to click at printer in the control board of computer.
2. You should close the “beginning bilarel support” in the “port menu” or you should close the “beginning bilarel support” in the backstage’s setting of printer inside the details.

  CLONNEN 17:49 11 Jun 2008

We have been searching through the list of built-in Vista drivers and there is something under USB Devices - Microsoft - USB Printing Support . It installs if we select it manually from the list but has a yellow exclamation mark next to it in the Device Manager and Properties states This device cannot start (code 10). The device driver details state its filename as usbprint.sys

The only reason we think this is the correct driver is because the little driver cdrom with the cable has a jpeg file on it which shows a USB entry entitled USB Printing Support (it's highlighted in the picture).

Is this the right driver? Why doesn't it install automatically? And what is code 10 error?

  woodchip 18:06 11 Jun 2008

Right click the yellow icon and choose update drive let MS look for a driver on the net

  CLONNEN 18:12 11 Jun 2008

We have tried the Update Driver button with the Automatically search for updated driver selected but it just puts it back on the Unknown Device no driver installed entry again.

  woodchip 18:16 11 Jun 2008

Try the adapter on its own, then if that loads OK plug the printer in

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment utiliser Live Photos ?