Packet Sniffer apps refusal to recognise driver?

  Chegs ®™ 11:23 04 Dec 2005

I have a Packet Sniffer app for windows called "Airopeek NX" I was interested in learning a little bit more about Wireless Network Security so when I saw this app for sale at a PC fair for a cheap price(£7 for 2 CD's off the selection)I bought it.It doesn't support my PCI card natively,but the dozens of "Readme's" included in the progs files indicate that the "PEEK" driver should/could be used and explains howto install the relevant data to enable the app to work.I followed the instructions carefully,and as can be seen in the screen-capture,the "PEEK" protocol is installed in the "Properties" of my PCI card.The problem is though the prog still insists that a "Custom Driver has to be installed" I have added each of the "Driver" folders assorted files,rebooted and tried the Airopeek app again,but just get the demand to have a custom driver to use the program.

So far,nothing has detected any packets on my WiFi network,I've tried "Netstumbler" "Ethereal" and a couple of others,these can detect the data traversing thru my wired router,but not from the WiFi card?

Any suggestions for either an app that will work with my Ralink 2500 card,or howto get Airopeek NX working with it?

Screenshot click here

  Chegs ®™ 17:26 08 Dec 2005


  bremner 19:47 08 Dec 2005

A colleague has had some success using Kismet click here

  Chegs ®™ 22:25 08 Dec 2005

Thanks for the reply,unfortunately Kismet is a linux app and I need a windows version as my linux knowledge is insufficient.I have several "live" CD's of linux based WiFi tools(Auditor/Whax/Troppix,etc)but compiling a kernel for the Ralink is totally beyond me.I couldn't even get the Ralink driver to install under Suse,as "Makefile" produced a "bash error:unrecognised command" (or similar)despite trying several ways of issuing the "make-file" cmd.

If I really have to,I will go look up the necessary info to use linux tools,but actually locating the relevant linux readme thats not "geek-speak" is quite hard.Linux forums get answers to my query,but the respondents always seem to assume my linux knowledge is as good as theirs(which if it was,wouldn't have me posting the questions in the first place)

  Chegs ®™ 21:31 12 Dec 2005

No-one able to help?

  De Marcus™ 22:29 12 Dec 2005

Of any interest? click here

  Chegs ®™ 22:45 12 Dec 2005

Thanks for those,there should be something of use in amongst them apart from those apps that need WinPcap as this produces an illegal op message on my laptop(98se)although this has only recently occurred as it ran other apps with WinPcap installed prior to my reinstalling 98se.

My desktop device is a pig,the Ralink card in it has been the cause of several difficulties with drivers under linux OS,then Airopeek won't detect the card regardless of which "driver" file I use with this app.No doubt,those apps in your link will find some fault with the Ralink as well but I'm gonna try them all anyway.

I was trying a Knoppix 4 Live CD version on my desktop lastnite,although the Knoppix CD picked up the card(Ra0 PCI card...cfg'ing)it stopped booting and I couldn't get to a usable desktop with it.I have used Knoppix Live 3.8 previously,its resolution to the Ralink was to simply ignore it and produced a "No driver" type message. ;-)

  Getphazed 06:22 17 Jan 2008

Been a while since last reply but incase OP is checking, with the ralink adapters you need to use ndiswrapper driver on linux, which is fairly easy to do but can be a pain, basically you use your windows driver on linux using ndiswrapper. I have a Airlink 300n pci card, I run Mandriva 2008 32bit edition and it works great. Just use the windows 2kXP .inf file you would find on the cd. If you need more help doing this post here and ill assist.

  irishrapter 18:12 17 Jan 2008

You should give "Remote Exploit" a go, click here to get it.

It is a live linux disk but there are lots of help on their forum if you need it. click here for the forum.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

Awful clip art from 1994 is being tweeted every hour by a bot

How to update iOS on iPhone or iPad

Les meilleures applications pour enfants 2017