Optical refuses to Autoplay

  anchor 10:24 28 May 2005
Locked

My new Evesham PC is fitted with two optical drives; a Sony DVD RW DW--D22A and a Philips DVD PCDV 6116.

The Sony writer will autoplay without problem, as does the external firewire drive, and the USB pen drive However, the Philips stubbornly refuses to autoplay. I can access the files without difficulty by opening My Computer and selecting the Philips drive, so no problem there. I have checked the autoplay settings for this drive in device manager, and found no problem; all settings correct.

I then tried the Microsoft Autorun fix, but this failed to correct the problem. The report is at the bottom of this posting. My next thought was to remove both the Philips and Sony drives from device manager, reboot and let Windows XP find them again. Done, but still no change. On contacting Evesham they suggested doing a sfc /scannow. This I did, (although I failed to understand that if some file was corrupted, autoplay works on the other devices).

Still no change; the Philips drive will not autoplay. Can anyone suggest a remedy?.


AutoFix [V5.2.3790.67]
Time [2005-05-25 09:13:58]
Microsoft Windows Version [5.1 (Service Pack 2) 2600>]

Test [The Shell Hardware Detection service is running.] - Instance [N/A]:
Result [AutoStart Setting]: OK
Result [The Shell Hardware Detection service is running.]: OK

Test [Policies] - Instance [F:\, Drive Type: 5]:
Result [HKCU\...\Policies!NoDrives]: OK {Absent}
Result [HKCU\...\Policies!NoDriveAutorun]: OK {Absent}
Result [HKCU\...\Policies!NoDriveTypeAutorun]: OK {Present}
Result [HKLM\...\Policies!NoDrives]: OK {Absent}
Result [HKLM\...\Policies!NoDriveAutorun]: OK {Absent}
Result [HKLM\...\Policies!NoDriveTypeAutorun]: OK {Absent}
Result [Driver level policies]: OK {
HKLM\...\Services\cdrom!Autorun (Present) Allows>
HKLM\...\Services\cdrom\Parameters!Autorun (Absent) Allows>
HKLM\System\CCS\Enum\...!AlwaysEnable (Absent) Not set>
HKLM\System\CCS\Enum\...!AlwaysDisable (Absent) Not set> }

Test [Drive Notification] - Instance [F:\, Drive Type: 5]:
Result [Legacy Notification]: Problems
Result [AutoPlay V2 Notification]: Problems {
Service (Silent)
Shell (Deaf) }
>> Repair [Autoplay V2 Event]
Step: No steps to take.
Result: This AutoPlay setting cannot be fixed. Either the device is malfunctioning, or the wizard cannot determine the problem.
>> Repair [Legacy AutoPlay Event]
Step: No steps to take.
Result: This AutoPlay setting cannot be fixed. Either the device is malfunctioning, or the wizard cannot determine the problem.

>> Required action: The wizard found problems but cannot fix them -> None

  anchor 10:27 28 May 2005

Oops!; The title should be:

Optical drive refuses to Autoplay

  Joe R 10:37 28 May 2005

anchor,

click here

  Joe R 10:40 28 May 2005

anchor,

sorry, i've just reread your thread, and you've already tried it.

Only other suggestion I could think of is to try another IDE cable.

  Fruit Bat /\0/\ 10:47 28 May 2005

Agree with Joe R try swapping the drives on the cable and see what happens.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

These brilliant Lego posters show just what children's imaginations are capable of

Mac power user tips and hidden tricks

Comment réinitialiser votre PC, ordinateur portable ou tablette Windows ?