Optical drives not loading

  Indigo 1 19:56 24 May 2004

Both my optical drives (CD-RW and DVD player) have just stopped working at the same time!

They do both happen to be on the same IDE cable too. Is this likely to be a mobo problem ?

They have both disappeared from "My Computer" and in Device Manager they both have yellow exclamation marks. Device Manager also says "Windows successfully loaded the device driver for this hardware but cannot find the hardware device. (Code 41)

Click Troubleshoot to start the troubleshooter for this device."

Needless to say "Troubleshooter" is useles.

I have tried uninstalling and re-installing and also disconnecting and re-connecting connectors.

Any ideas

Win XP Pro. ABIT AT7-MAX2 Athlon XP2600 Barton, 1024 Mb RAM etc.

  Mister Splendid 20:04 24 May 2004

First thing to do is to try a different ide cable you know to be ok.

  Fruit Bat 20:07 24 May 2004

Primary /secondary ide controler showing yellow exclamation mark?

  Charence 20:07 24 May 2004

Do the drive work? Power should still be going to them, try ejecting the CD drawer and check if the LEDs flash when PC boots up. If possible I'd recommend that you test them on another machine or buy CD/DVD drive from a shop to see if they work.


  Indigo 1 20:14 24 May 2004

Everything was working just fine this morning but when I got home from work I noticed that the PC had re-booted itself and now the drives are not registering. I have not turned it off for all that time except to intall updates etc. and that is usually just a re-boot.

I have been using this PC as it is without change for about 4 months, the only problem I have noticed recently was the PSU fans stopped turning and the PC got a bit hot last Monday so I just selected a different setting for the fans (switched from Auto to Med) using the external switch and left it at that.

  Indigo 1 20:17 24 May 2004

They are both on the secondary IDE channel, the HDD's are on the primary.

The IDE channels do not indicate a problem.

  Indigo 1 20:21 24 May 2004

Both drives appear to be working OK, lights flash and they load and eject discs when a disc is inserted they both flash their LED's in recognition and the discs spin up to speed but windoze does nothing.

  Indigo 1 21:48 24 May 2004

Just tried sytem Restore out of desperation .....still no luck.


  Fruit Bat 21:56 24 May 2004

Try putting the slave optical drive as slave on primary ide cable to check if drive working.

If ok then must be seconbary ide /mobo problem.

  Indigo 1 22:39 24 May 2004

Will try that tomorrow.

I was thinking along those lines anyway, I would have preferred it to be software related as this mobo was a replacement for a different faulty mobo and is still less than 6 months old !

Ah well here we go again !!!

  Indigo 1 09:11 26 May 2004

Resolved thanks to €dstowe see this thread click here

Thanx to all who tried to help.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

Halloween Photoshop & Illustrator tutorials: 20 step-by-step guides to creating spook-tacular…

iPhone X news: Release date, price, new features & specs

Comment créer, modifier et réinitialiser un compte Apple ?