Optical drives not found

  guesswho2 11:54 09 Nov 2010
Locked

Out of the blue when I tried to copy something to my DVD writer got message saying optical drive not found, or words to that effect.
When I look in My Computer neither of my 2 optical drives is listed. Device Manager shows a yellow mark at both.
I'm running XP home, SP3 with everything else working as far as I know.
Any suggestions please.

  Gongoozler 12:14 09 Nov 2010

Are the drives detected in BIOS?

  Gongoozler 12:18 09 Nov 2010

If they are detected in BIOS, try this click here

  guesswho2 14:15 09 Nov 2010

Thanks Gongoozler I thought that website had done the trick because the two drives reappeared in My Computer and they would both read discs again, but I can't get the rewriter to record. It doesn't know when a disc is put in the drive. I'm using Ashampoo9 which I've been very happy with for a while. May be I'll try a freebie and see how that goes.

  KremmenUK 14:28 09 Nov 2010

have a look in the registry and perform a global search on the term 'lowerfilters' followed by 'upperfilters'.

If they exist then do a Google on them and follow the steps to remove them.

  Fruit Bat /\0/\ 17:06 09 Nov 2010

No CD/DVD or CD-ROM access is missing error Code 19, Code 31, Code 32, Code 39, or Code 41
Try this if the optical drives are not appearing in My Computer or Device Manager.
(This is sometimes caused by the removal of Roxio or other writing software.)

click here
Download XP_CD-DVD-Fix.zip and save this file to your hard drive. Navigate to where you saved it and double click the file to extract the contents. Locate the EXE file you extracted and double click it. A confirmation dialog will appear when the script is done. You may need to reboot for the change to take effect.
This utility is only intended for Windows® XP, but also appears to work for Vista and Windows 7.
You may need Administrator level access to use this utility. If you do not have Administrator level access, the program will say it is finished, but will not have made any changes.

Similar fixes
click here works for vista or XP
click here

or manual fix
Run regedit and navigate to registry key
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\ {4D36E965-E325-11CE-BFC1-08002BE10318}.
Highlight it and in the right pane, find the Upperfilters and Lowerfilters values.
Highlight each one in turn, right click and delete them.
Close regedit and restart the computer.
If in doubt make a restore point before making changes.

  guesswho2 18:19 09 Nov 2010

I've deleted Upper Filter as suggested but no further forward. The drives are showing up OK, just that the rewriter won't write. I've just re-enabled a QuickTime Plugin but that didn't help.
Getting repeated Error 7026 "The following boot start or system start failed to load Lbd"

  guesswho2 19:16 09 Nov 2010

I have found Lbd in System 32/drivers when I run System Information, where it shows it to be Inactive and a Boot Start.
Might this be the root of the problem and if so can someone suggest what to do now?
Just to recap, the drives now show up OK and they will read but the rewriter won't!

  guesswho2 20:07 09 Nov 2010

Just for the record, I regularly run SuperAntispyware, Spybot and I've just run TrendMicro HouseCall. AVG free runs all the time so I'm fairly sure this is not malware related.
Could Gongoozler maybe get back to me some time re checking if drives are detected in the BIOS. I don't know how to do that.
I'll look in again tomorrow.
Many thanks to you all.

  Fruit Bat /\0/\ 20:25 09 Nov 2010

No Lbd in sstem32 drivers in XP home SP3.

I suggest you scan for viruses and malware

  Dark Mantis 21:10 09 Nov 2010

You haven't configured your ports to run in AHCI mode have you?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

Alice Saey's mesmerising animation for Dutch singer Mark Lotterman

iPad Pro 10.5in (2017) review

Comment booster votre iPhone ?