OpenAL - can I get it on my audio?

  chrismuir 20:14 31 May 2007
Locked

Bought Quake 4 and installed it. When i ran it there was no audio. Went into the settings and found the message your sound device do not support OpenAL. I have a built in audio card on my motherboard (Gigabyte GA-7DX+), will it support OpenAL, do I need to install some new drivers or do I need a new sound card?

This is the first game I have bought that has had this sort of problem, is it likely to be a common event with newer games?

MTIA

Chris

  brundle 20:24 31 May 2007

"If you select OPENAL in the Quake 4 menu and the game crashes all the time and it will not give you the choice to Unselect OpenAL just open the game directory ,Open q4base then look for the Quake4config file then open it with notepad, look for 'seta s_useOpenAL "1"' and change the '1' to a '0' this will switch off the OpenAL support and let you put the game on again - It saves you having to uninstall all the time."

quote from click here

  chrismuir 23:12 31 May 2007

Ooops, my mistake.

I saw the message 'your sound card does not support OpenAL' and thought that was the reason I was not getting sound. The OpenAL support is already turned off in the config file.

The audio works fine on other games, it just doesn't work at all in this game. Is there anything else I can try?

The built in sound is using NVidia nForce audio.

Chris

  brundle 00:27 01 Jun 2007

Q4 worked on my mobo which also has NForce (2) audio...

More on OpenAL click here but not a lot of help...

Usual advice, install latest drivers, latest DirectX (april 07 - click here) - patch quake to 1.41, some troubleshooting ideas here; click here

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review: Hands-on

Illustrator Andrés Lozano on his improv line work, brazen use of colours & hand sketching

iPhone X review

Comment envoyer gratuitement des gros fichiers ?