Office HELP files Problem with Ouactrl.ocx

  Simsy 06:28 05 Sep 2007


I've just discovered I've a problem with MS Office 2000 help files...

It seems some of the information is via little "pop ups" and clicking on some of the internal links produces the following error message;

click here

I've searched MS help and found some links which relate to the issue;

click here
click here
click here

... but they only explain what the issue is, and why the update, which changes the .ocx control, is applied, but not how to rectify it and get full function of the HELP files back.

In summary, it seems that there is a possible security issue with the original .ocx file. (Further internet searching indicates that it's an avoidable risk; "social engineering" is involved). The update puts a newer version of this file in place which eliminates the risk...

I've tried, I think, everything, including completely uninstalling Office, so the file doesn't exist on the system at all, (the file is contained in the "Office" folder, not the "Windows" folder), and reinstalling. But that doesn't work, with the message still appearing. I've downloaded the original .ocx and replaced the updated file with it... but that doesn't work. I've deleted the file altogether, but then when starting HELP Office goes into its, installing/configuring sequence, and the NEW version of the file appears, with the error warning appearing.

Can anyone advise how I can get full function back in my HELP files?

Thanks in hope!

(Office 2000, Win XP home)



  Simsy 06:29 05 Sep 2007

I have tried reducing the browser security setting.



  Simsy 19:14 05 Sep 2007

Any Takers?



  alanth 12:48 06 Sep 2007

I had the same problem recently

Like you I tried all sorts of solutions eg. installing the new version of ouactrl.ocx, deleting it, even reinstalling Office from scratch, but no joy.

In desperation I turned to System Restore. I had installed some Microsoft Security updates recently so I restored before that. Lo and behold, everything back to normal.

Then a few days ago I was offerred updates again (I have Automatic Updates set to inform me before install). I installed them and yes Office help screwed again. System restore again fixed it.

I do not know which update it is (there were about ten) but next time I will install one at a time to find out.

I am running Windows XP with Office 2000 (upgraded from 97)


  Simsy 15:37 06 Sep 2007

unfortunately I do not have a position to restore to... a bit too brutal with my clean up before making a "True Image"

But thanks... good to isolate it a little!

I would be interested to see if you can identify which one it is. I may be able to "uninstall" it from the uninstall files.



  alanth 12:13 14 Sep 2007

The update that caused the problem is KB937143 - a general security update for Internet Explorer

Amongst lots of other things (which are probably good) - "This update sets a kill bit for the ActiveX control, ouactrl.ocx, that is out of support:"

This should stop Internet Explorer opening the control in a browsed web page so why it affects Office Help is beyond me, but turnig it off solves the problem.

You need to edit the registry and delete the following key

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\ActiveX Compatibility\{8936033C-4A50-11D1-98A4-00A0C90F27C6}

Make sure you backup the registry and/or take a system restore checkpoint first just in case

Good luck

  Simsy 22:58 18 Sep 2007

Sorry for not responding sooner... I've been away for a few days.

I've just found the key, and deleted it, (after making a backup!), and the problem is half solved;

I no longer get the error message... but I dont get the extra information that is suppossed to appear either!

Still, with you identifying the KB involved I may be able to achieve some more!.

Many thanks for your help, time and advice, on this tricky one!



  alanth 09:13 20 Sep 2007

I had that symptom during my original efforts to fix. It occured when I installed version 2 of ouactrl.ocx so I reverted to the original which I still have (version

You could try replacing with the old version, If you haven't still got it send me an e-mail Click on my name at the top of this reply) containing your E-mail address and I will send you a copy.

  Simsy 09:22 20 Sep 2007

I think I've still got it, so I'll try that.



  Simsy 09:33 20 Sep 2007


Much appreciate your help.

Now to make a backup image!



This thread is now locked and can not be replied to.

Elsewhere on IDG sites

The Evil Within 2 review-in-progress

Adobe shows still-in-development tools, including automatically colourising black-and-white photos

iPhone X news: Release date, price, new features & specs

Comment transformer un iPhone en borne Wi-Fi ?