An obscure network problem

  spargo 16:00 05 Mar 2006
Locked

First the setup

Main computer (A) Win XP Pro. SP1 connected to Belkin router/modem (F5D7630-4A) via ethernet.
Second computer (B) Win 98SE with wireless dongle.
Third computer Laptop (C) Win 98SE with wireless card.

A, B and C connect to the web with no problems.
A, B and C can all 'see' the others on the network (all can ping each other with no problems.)

They have individual names on a common network and appear in 'Network Neighberhood' on each computer.
They all have folders designated as 'Shared' and the printer on A is also 'shared'.
All these shared folders appear on the desktop of any of the three computers when requested
from any other computer, exactly as you would expect.

Now the problem,

File sharing works perfectly between B and C in either direction.
Files can be 'sent to B or C from A
File sharing works between A and B and between A and C but only in one direction.
Printer Sharing B to A, or C to A does not work.
A can access files as normal on B or C but when trying to access files on A from B or C ie trying to
open A's 'shared folders on B or C desktop an error is given,

\\ A\ shared folder is not accessible.
Not enough memory available.
Quit some programs.

Everything used to work OK, something has changed but what?
Have tried with all Firewalls off, AVG off on all computers, no difference.
Have checked all settings, run SFC on A

Any ideas anybody?

  Maturin 21:16 05 Mar 2006

Spargo - my 'home network crashed' thread was a a similar problem, also with a Belkin router at the centre of my network. My computers are setup differently (Win XP all round) but what has worked for me is uninstalling and reinstalling the firewall program(s) AND manually configuring the TCP/IP settings for each machine,
ensuring that they all have the same IP tagline (eg 192.168.1.x, where x is a unique number for each machine and 192.168.1.1 is the IP address for the router)
AND
the subnet mask is the same for all machines (eg 255.255.255.0)
AND
DNS setting is the same as that in the Belkin setup window on the 'Home' screen'

Everything works, although wireless connection for Desktop PC does not connect - the wired connection is faultless (and faster :-))

Hopefully this is helpful

Maturin

  spargo 22:18 05 Mar 2006

Maturin

Thanks for the reply. Will try it in the morning and let you know how I get on.

  spargo 18:42 09 Mar 2006

Maturin

Sorry I have been so long getting back to you, other things got in the way. I tried your suggestions but had exactly the same errors. As the A computer is a dual boot machine I set up the network on the W98 side, It worked perfectly. This led me to belive it was something in winXP that was causing the probs.
Having checked everything (again!) I uninstalled the 'File and Printer Sharing' in the network properties and then re-installed it. This cured the problem.

Thanks for your help

Spargo

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

Awful clip art from 1994 is being tweeted every hour by a bot

iPhone X vs Samsung Galaxy Note 8

Les meilleurs navigateurs internet 2017