NTOSKRNL.EXE missing even after recovery disk

  bhski 22:11 04 Dec 2008

I am running an HP Pavilion with Windows Media center 2005.

My hard drive crashed a couple weeks ago. I sent it to a friend for evaluation and he said that multiple sectors were corrupt and the operating syatem data in these areas are unreadable. His recommended course of action was to order a system recover disk and new hard drives. I received the new hard drives and system recovery disks yesterday.

I installed the new hard drive and started the recovery process. I was prompted through all three disks. At some point during the 3rd disk I received the NTOSKRNL.exe error again stating the file was missing or corrupt.

I am confused by the scenario. New Hard drive + HP recovery disks = NTOSKRNL.EXE missing or corrupt. Does anyone have an Idea at what is happening?

I am well past my warranty from HP. I would purchase the support but I am afraid my answer will be: thank you for purchasing support, but your motherboard is bad and you need a new PC.

  MAT ALAN 22:17 04 Dec 2008

Try another keyboard...

click here

  iqs 22:22 04 Dec 2008

can you try the install again?

  Fruit Bat /\0/\ 22:55 04 Dec 2008

You can use the Recovery Console on your Windows CD .

Once at the command prompt, type in the following commands:

cd c:\windows\system32

copy "..\driver cache\i386\ntoskrnl.exe"

If prompted to overwite the existing file, type y and enter.

If you receive a file not found error, make sure that the path in the copy command is correct. If it is correct and you still receive the error, then try the following commands:

cd "c:\windows\driver cache\i386"

expand sp1.cab -F:ntoskrnl.exe c:\windows\system32

Again, if you are prompted to overwrite the file, type y and then enter.

Also, if your OS is installed on a partition/drive other than C:, then replace any occurance of C: with the correct letter. (D: for example).

Replace any occurence of 'windows' with what is appropriate for your system. (winnt for example)

Reboot. Your system should start up normally.

  bhski 23:11 04 Dec 2008

I am having keyboard issues, but I tried a second keyboard and still had issues. Could it be a short in the PS2 port?

I will take a USB keyboard home and try it.

The keyboard problem has not allowed be to do any of the boot menu options as it goes by.

I will try the other solutions tonight, if I can get a keyboard to stay recognized.

  bhski 15:53 05 Dec 2008

I was able to reinstall my system last night. I think I have isolated the issue. It appears there are multiple issues.

1. My PS2 port is not fully functioning. The optical light works on the mouse but does not move when the mouse moves. (This mouse works perfectly fine on another computer) When I plug in a non optical mouse it does not work either.

2. If there is a USB mouse plugged in the computer goes to the NTOSKRNL.EXE error. (Tried 2) I can have other USB devices plugged in, but not a mouse. I have to turn the machine on with no mouse and plug it in after the fact.

Is there a toggle for #2 somewhere that can be adjusted???

  Fruit Bat /\0/\ 15:57 05 Dec 2008

Check in the BIOS that the options to boot from USB devices is switched OFF.

It appears your machine is trying to boot an operating system from the USB mouse.

  woodchip 16:05 05 Dec 2008

In Device Manager uninstall the Compliant Mouse then restart your computer and plug the USB mouse in

  bhski 03:07 06 Dec 2008

I am having difficulty getting into the BIOS. Is there a toggle that is not allowing my keyboard to function during bootup. My options are ESC F1 and F10 on the bootup screen. Even if I alternate keys throughout the entire booting process it goes straight into Windows.

I have gone into the BIOS on other machines...but this one seems to have some weird settings.

  MCE2K5 03:30 06 Dec 2008

Does this help, click here={f14dd60b-4a52-4aef-ab73-7f3d922e1a3c}&CatID={582137b6-6167-49d9-9e2f-057c56f81654}

  woodchip 14:35 06 Dec 2008

You need to use a PS/2 keyboard to get into BIOS then set all USB to enabled

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review: Hands-on

Illustrator Andrés Lozano on his improv line work, brazen use of colours & hand sketching

iPhone X review

Comment envoyer gratuitement des gros fichiers ?