ntdll.dll errors in xp home.

  hugh-265156 00:19 30 Jul 2003

hi all,i have windows xp home etd.

this past few days i keep getting "and error has occured in explorer.exe and needs to close"

this happens when i click on any file or folder or when im just browsing the net.i recieve the above message,and windows returns to the desktop i cannot nail it down to any one program causing the problem.i have not installed any programs for a few weeks apart from avg updates and windows updates.

i had a look in event viewer and the error is listed as"faulting application explorer.exe version 6.0.2800 1221 faulting module ntdll.dll version 5.1.2600.1217 fault address 0x00007ec4"

i have tried windows help and support and although there is ntdll errors listed,none seem to relate to my problem.

i normally keep a few restore dates and have restored to both(when i did not have this problem)and it still happens.i have also tried sfc /scannow and even replacing ntdll.dll with a downloaded version.no joy.

i have 81MB used out of 512MB,spybot s&d,avg,all up to date and report no problems.

  hugh-265156 11:30 30 Jul 2003


  Xevious 12:16 30 Jul 2003
  hugh-265156 12:52 30 Jul 2003

thanks for the reply Xevious.i have version 5.1.2600.1217 and all the critical updates.

my problem is crashing to the desktop when any file or folder application is clicked eg/ my docs folder or a file on the desktop or when i click explore all users.i can then click again and they open ok.

the only error in event viewer is as above listed in application.

avg reports all clear.i have used spybot and checked for nasties and registry inconsistencies,sfc /scannow,chkdsk and defrag all ok.

  Xevious 12:59 30 Jul 2003

it's a long shot, but have you tried replacing the ntdll.dll file? (backup your version first!)

click here to get the ntdll.dll file

  hugh-265156 13:57 30 Jul 2003

see my first posting please.

  hugh-265156 16:48 30 Jul 2003


  hugh-265156 10:38 31 Jul 2003


  hugh-265156 12:08 01 Aug 2003

its fixed now i think(has not crashed since yesterday afternoon.before this was happening twice an hour or so).

it was really starting to bug me so i used jv16 power tools to check the registry and found nothing,zip. i decided to start removing my last installed programs.the last thing installed was diskeeper lite a few weeks back.removed it and all seems back to normal again.

didnt really like it anyway,windows built in defragger does the job in a few mins.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

Awful clip art from 1994 is being tweeted every hour by a bot

How to update iOS on iPhone or iPad

Les meilleures applications pour enfants 2017