Notepad starts as command prompt

  Charlie Brown 16:31 03 Jul 2004
Locked

My notepad has recently started opening as command prompt with a black box and not as a text window. How can I correct this?

  Pesala 16:36 03 Jul 2004

Right-click on the shortcut that you use to launch it, click on properties, and copy what it says in the Target field. It should be something like this:

C:\WINDOWS\NOTEPAD.EXE

  Charlie Brown 16:50 03 Jul 2004

Thanks, Pesala. Correcting the target field to C:\WINDOWS\notepad.exe now makes the notepad open when I open it from Start-Programs-Acc-Notepad. But when I click a text document in Windows Explorer it still opens as command prompt. How do I correct this?

  VoG II 16:52 03 Jul 2004

Right click a document and select Open With. Select Notepad from the list presented and tick the box to always use this application.

  Charlie Brown 17:20 03 Jul 2004

VoG, I have tried this, I tick the box to always use this application, but their is no apply box to tick and when I come back to this the tick has dissappeared.
Also, when the command prompt window opens, it says on top C:\WINDOWS\system 32\Notepad.exe.

  VoG II 17:45 03 Jul 2004

click here TXT file association fix.

  spikeychris 17:55 03 Jul 2004

Just out of interest, paste the below into run

%SystemRoot%\system32\notepad.exe

What happens?

  Charlie Brown 18:20 03 Jul 2004

VoG, the TXT file association fix did not work.
What do I do now?
As for the suggestion of spikeychris, pasting what he has written, just flashes open the command prompt window for a second and then it closes.

  spikeychris 18:27 03 Jul 2004

Start, run, type command (anything cept 2K XP) type cmd for 2K XP in the command box paste

%SystemRoot%\system32\notepad.exe

What happens?

  VoG II 18:52 03 Jul 2004

Also

Start, Run, type in

regedit

and click OK.

In the left hand pane navigate to the following keys and see what is displayed in the right hand pane under "Data".

HKEY_CLASSES_ROOT\txtfile\shell\open\command

HKEY_LOCAL_MACHINE\Software\CLASSES\txtfile\shell\open\command

Don't attempt to fix anything in the registry, just close it and post back what you found.

  spikeychris 19:00 03 Jul 2004

Also...

Pulling the plug so if you use XP and you have the disk


Start, run msconfig ok, click on General tab> "expand file"

File to expand: notepad.exe
From: X:\I386
To: %windir%

Change X to the letter of your CD drive


If its a preinstalled machine look for a copy of the notepad file in the C:\Windows\I386 folder

Or just use SFC /scannow (just sfc if win98) to repair the installation

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best phone camera 2017

Stunning new film posters by Hattie Stewart, Joe Cruz & more

iPad Pro 10.5in (2017) review

28 astuces pour profiter au mieux de votre iPhone