No recorder

  sajeev 22:58 20 Mar 2009

My Sonic RecordNow 7.3 LE suddenly says No Recorder and wont allow me to burn a disc.
What can I do to rectify this?
Thanks in advance

  Fruit Bat /\0/\ 23:04 20 Mar 2009

No CD/DVD or CD-ROM access is missing error Code 19, Code 31, Code 32, Code 39, or Code 41
Try this if the optical drives are not appearing in My Computer or Device Manager.
(This is sometimes caused by the removal of Roxio or other writing software.)
click here
Download and save this file to your hard drive. Navigate to where you saved it and double click the file to extract the contents. Locate the EXE file you extracted and double click it. A confirmation dialog will appear when the script is done. You may need to reboot for the change to take effect.
This utility is only intended for Windows® XP, but also appears to work for Vista.
You may need Administrator level access to use this utility. If you do not have Administrator level access, the program will say it is finished, but will not have made any changes.

Run regedit and navigate to registry key
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\ {4D36E965-E325-11CE-BFC1-08002BE10318}.
Highlight it and in the right pane, find the Upperfilters and Lowerfilters values.
Highlight each one in turn, right click and delete them.
Close regedit and restart the computer.
If in doubt make a restore point before making changes.

click here

  sajeev 00:10 21 Mar 2009

Thanks FruitBat.
The first option (XP-CD..) did not work even after rebooting.I did not get the "Done" message.
As for the regedit I have got as far as highlighting the long number 4D36..... However the right pane does not show anything called Upperfilter or lowerfilter value.
It shows a list consisting of Default, Class, Enumpropages,Icon, Installer32, NoInstallClass,SilentInstall and Troubleshooter.
How do I proceed?
I forgot to mention that I have the original Sonic
RecordNow CD. Will that help?
I tried the last 'click here" and it opened up some fairly complicated files with warnings etc, so am a bit lost.
Have set a new restore point.

  Fruit Bat /\0/\ 14:00 21 Mar 2009

Ok so you have no upper or lower filters - that's fine

The last click here should open a download called CDgone save it and then double click the downloaded file to run it.

If still no good the reload the Sonic program and see if things improve.

  sajeev 15:33 21 Mar 2009

Fruitbat, thanks.
I ran CD-gone and rebooted: No change
Reinstalled Sonic from original disc: no change
Any other ideas?
I am in a fix as at this time of the year I need to put my annual accounts on discs and time is running out!
Any help welcome

  Fruit Bat /\0/\ 17:02 21 Mar 2009

1. is it showing in device manager? without any exclamation marks against it.
2. if so try another writing program.
3. if still no good then it looks as if the drive has failed.

A new DVD RW drive is less than £20.

  sajeev 17:13 21 Mar 2009

Device manager shows the the SONY CDRW/DVD drive is working properly.
Shall look for another writing program on the web.

  AllThumbs 00:41 22 Mar 2009

Can't help you with the first part of the problem, however a free recorder that I've used perfectly happily is InfraRecorder

click here

perfectly good cd/dvd writing tool

  sajeev 19:23 24 Mar 2009

Sorry for the delay-internet problems on top of everything else!
I had already downloaded a free program called FinalBurner and that seems to be working okay.
Shall make a note of InfraRecorder fo the future.
Thanks to everybody for the help.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Lightwell software lets you create mobile apps without using code

Best value Mac: Which is the best £1249 Mac to buy

Comment désactiver les programmes qui s'exécutent au démarrage de Windows 10 ?