no power to laptap

  nyleridedog 10:02 10 Sep 2007
Locked

Hi guys i have read thru all the threads below detailing help for laptops that wont power up!

No luck using those tips!

One thing i have though, is a little light on. its a battery with a thunderbolt thru it! any ideas what it is?

the machine will not turn on! its a medion notebook model mim2120

any ideas to try

cheers

  wee eddie 10:16 10 Sep 2007

Have you tried it while it is connected to the Mains

Does the Battery show any signs of Charging/

Is there any possibility that the Mains Connection has been knocked while Charging?

  nyleridedog 10:31 10 Sep 2007

thanks for the quick reply eddie

i have tried it connected to the mains with no battery but still just get the same light on(battery with thunderbolt)

the mains connector is ok.

cheers

  nyleridedog 10:36 10 Sep 2007

i have noticed that the psu is a HP one!
the notebook says input is 19v 3.42a max + * -
psu has output as 18.5v 4.9 a 90w - * +

any help to anyone?

cheers

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

Awful clip art from 1994 is being tweeted every hour by a bot

iPhone X vs Samsung Galaxy Note 8

Les meilleurs navigateurs internet 2017