No Network or internet

  PhiltheFragger 15:36 05 Jun 2009
Locked

This will test you.

HP XP laptop will not connect to a wifi or rj45 connection, constantly seeking ip address.

router works with all the other pcs no worries and rj45 cable is good.

have run winsock fix, taken out TCP/IP and reinstalled it, checked that it is set to automatically get the ip address.

uninstalled kerio firewall just in case
run malwarebytes which came up with nothing significant, no trojans
have reset internet explorer.

Uninstalled the realtek rj45 driver & reinstalled.

Anyone have any suggestions what to do next

Cheers

Fragger

  tobyb121 18:13 05 Jun 2009

Check that the router doesn't have reserved ip addresses or an acess list, these would give you these problems, also make sure your laptop is set to get ip dynamically from router, i.e. not setup with a static ip

  PhiltheFragger 18:40 05 Jun 2009

Done, still the same problem

Also tried to do a system restore, which failed

methinks a reformat is on the cards

  ambra4 19:12 05 Jun 2009

Check that the Lan card and network is set up correct

Click - Start-Settings - Network Connection

Double - click on the “Network Connection”

Right click on the “Local Area Connection” associated with the network adapter

Select “Properties” from the drop-down menu.

In the “Local Area Connection Properties” window all boxes should be ticked

At bottom of display tick the box “Show Icon in Notification Area When Connected

A display Icon will appear in the task bar when you have finish the setup

Click-Internet Protocol (TCP/IP) Click the “Properties” button

Select “Obtain an IP address automatically

Select “Obtain DNS server address automatically”

Click- Advanced-Click-WINS Tab-Tick-Enable LMHOSTS Lookup if untick

Do Not Change Any Other Setting

Click “OK”.

Your computer network card is now configured for use with the Modem/Router


Other Lan Card Setting

Right click on Local Area Connection Display Icon on task bar

Click Status-General-Properties

At the top of display the type of Lan card will be displayed

Click- Connection Type - Change to “Auto- Negotiation”

Click- Flow Control-Change to “Hardware Default (Auto)”

Click-Power Management Tab

Un-Tick if selected "Allow Computer to turn this device off to save power


Network Connection Setting

Click-Start- Setting-Network Connection-New Connection Wizard

Select-Connect to the Internet-Next

Select-Set Up My Connection Manually-Next

Select-Connect using a broadband connection that is always on

Next-Finish

  ambra4 19:19 05 Jun 2009

Most laptop computer these days comes with a build in wireless card; some required you to switch on

the “Wireless Radio Antenna” via a small slide switch on the laptop

Or using the FN (Function) key you have to hold down the FN key and press the key with a small

antenna icon to turn on the “Wireless Card Antenna”

Check that the wireless card is “Enable” from inside the Network Connection Area

Start-Setting-Network Connection-Right click-Wireless Area Connection-Enable or Disable as

required

If already “Enable”

Disable and Re-Enable the wireless card and see if it will connect to the Router system

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

HP’s new Surface Pro rival is designed specifically for Adobe-using designers and artists

Best kids apps for iPhone & iPad

Que faire si son iPhone ou iPad est tombé dans de l'eau ?