No longer able to connect to my Powerline Network

  Mbube 23:50 11 Jan 2011

Nearly a year ago I bought 2 Powerline Ethernet Adaptors to boost my Wi-Fi signal via my electric circuit so as to be able to connect my Windows 7 laptop to the internet when out of range of my Belkin router. This worked perfectly until yesterday.

I have just replaced my dead printer with a new Wi-Fi one and decided by way of an experiment to connect it to my Powerline network and then print a document from my laptop in another room. The printer messed up printing the document so I reconnected it to my main Belkin network and printed the document again from my PC. It may be a coincidence but immediately afterwards I was no longer able to connect my laptop to my Powerline network it says limited availability even when I have the laptop right next to my 2nd Powerline adaptor. When I take the laptop back to within range of the 1st adaptor which is connected to my Belkin router via an Ethernet cable I have no problem connecting to my Powerline network. There is nothing wrong with the 2nd adaptor because I have swapped them over and got the same result.

When I troubleshoot the problem (with Windows) it says “Wireless Network connection doesn’t have a valid IP configuration” I have looked at the user manual on the disk that came with my Powerline adaptors and tried resetting the IP address on my laptop but this hasn’t helped. Does anyone have any idea what the problem is and how I might solve it. Any help would be greatly appreciated thanks.

  Mbube 00:12 12 Jan 2011

I have just realised I said when I try to connect to my Powerline network it says "limited availability" and I should have said "limited access" it then says "unable to connect" despite saying "signal strength excellent"

  dms_05 08:13 12 Jan 2011

It sounds as if your experiment with your printer has switched the network to one not recognised as your old network for connecting your computer. Is it posible to 'reset' the Powerline adaptors? Mine came with a DVD that contained a utility allowing this sort of action.

  Mbube 20:06 12 Jan 2011

Thanks dms_05,

The disk that came with my Powerline adaptors has just two files Power Packet5.0.1.7_Setup and PL-85PEW_MK2 User Manual. Although I've installed Power Packet I'm not entirely sure if I need it or what it does.

Reading through the manual I've tried following the setup instructions again but so far all I've managed to do is go around in circles and end up back at square one. With the laptop set up next to my PC when I try connecting to Powerline it doesn’t work and then when I try connecting to Belkin that doesn’t work either. If I troubleshoot Belkin it says “DHCP is not enabled” and then fixes this problem I can then sometimes connect to Belkin however the only way I can be sure of connecting to Belkin is to switch off my 1st Powerline adaptor.

If I switch it back on and try connecting again not only can I then not connect my laptop to Belkin for the same reason as before but it also seems to mess with my PC’s connection. When I troubleshoot my PC it says “Reset the network adaptor local area connection 2” which fixes the problem. When I try and troubleshoot powerline on the laptop it usually tells me there is a problem with my router which there clearly isn’t if the internet connection is working fine on my PC.

If I try to connect the laptop to Powerline via the 2nd adaptor I get the same message I was getting originally “Wireless network connection doesn’t have a valid IP configuration” Also if I right click Powerline and then Status and then Properties for IPv4Connectivity it says “no internet access” and if I then click Details, for DHCP enabled it says “no”.

The adaptors have a reset button on them which I’ve pressed using a paperclip but this hasn’t made any difference. Given the problems with connecting to Belkin it would seem that I need to ensure that DHCP is also enabled for Powerline but I don’t know how to do this or how to change IPv4Connectivity so that it says “internet”. Any further help would be very welcome

  Mbube 00:10 13 Jan 2011

After a quick Google search for Powerline produced lots of results for Netgear adaptors I realise I should have said that my adaptors are Solwise (PL-85PEW_MK2).

  dms_05 19:18 13 Jan 2011

I had a problem with my son's Powerline network so I did the following:

Plug the two Powerline Adaptors into adjacent sockets (I used two in a 4 socket extension lead). This means they are as closely connected as possible and cuts out mains wiring problems.

Connect Powerline adaptor 1 (PL1) to the computers LAN socket with a LAN cable. Connect POwerline adaptor 2 (PL2) to the Router with another LAN cable. You now have a PL Network that you know is complete. Try connecting to the Internet.

I'm concerned you are reporting “Wireless network connection doesn’t have a valid IP configuration” as this indicates you are using the wrong network adaptor in the computer. You seem to be using the WiFi connection rather than the LAN connection. The 'error' is quite correct, you won't be seeing anything on this hardware as it's not in use.

  Mbube 19:47 14 Jan 2011

Thanks again,

I tried plugging the two adapters in side by side and then connecting one by cable to my laptop on my last attempt I was unable to connect to Powerline and swapping the adaptors made no difference all the happened was that I was unable to connect to Belkin. Last night I managed to connect via PL1 and accessed my homepage so I then walked with the laptop through to where PL2 is plugged in and the signal strength at first went right down but then came back up and it looked like I was still connected until I tried to use the web and then I got limited access again.

I have just tried checking the adapters using Power Packet Utility which I have installed on my PC and on the laptop. When I run it on the PC with the two adapters plugged in side by side at the top under Local Device(s) on your computer it shows Device Type “HomePlug Turbo Device” followed by the Mac address and then says “Connected to HomePlug Turbo Device”. Then below it says “1 Powerline device detected” under that for Device Name it says Device 2 then the Password then under Quality it shows just one bar and under Rate 9.00 (mbps) and then the Mac address for this device. If I swap them over for Device 1 it doesn’t show a password and under Quality there are 9 bars and under Rate 85 (mbps). I don’t know but this suggests to me that maybe there is a problem with Device 2 though I’m not sure why there should be.

If I run Power Packet on the laptop before it opens it says “Database file is not present. Click OK to continue” then when it opens it says “HomePlug adapter not detected”.

I’m not sure what else to try? I don’t want to have to replace one or both of the adapters and certainly not without knowing what the problem is first.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iPhone X review

Political cartoons in 2017: Chris Riddell, Rebecca Hendin and Dave Brown on what it’s like to…

The best iPhone for 2017

Tennis : comment regarder la finale de la Coupe Davis 2017 ?