No Internet - Sony Vaio

  yorkshirecath 14:15 04 Feb 2014
Locked

So i have a Sony Vaio and it has suddenly just decided the internet doesn't want to work. I have the bars in the bottom right with a yellow ball over them (it was a red cross but i think i updated a driver and now it's changed to that), it just says limited access. I have also tried attaching to my modem with an Ethernet cable and that won't connect either. In my adapter setting it shows 4 connections: Bluetooth (not connected) LAN - Realtek PCIe GBE Family Controller (network cable unplugged) Wireless Network Connection - Atheros AR9485WB-EG Wireless Network Adapter (Enabled) Wireless Network Connection 3 - Microsoft Virtual WiFi Miniport Adapter #2 (not connected)

If i troubleshoot it says:

There may be a problem with the driver for the Local Area Connection Adapter

There may be a problem with the driver for the Wireless Network Connection 3 Adapter

A bit more info about the computer - It has Windows 7 Home Premium on it which came installed. Its an Intel Core i3

Thanks for any help!!

  Fruit Bat /\0/\ 14:43 04 Feb 2014

Check in device manager for exclamation marks against the network controller drivers and update or reinstall

Realtek PCIe GBE Family Controller driver here

Atheros AR9485WB-EG Wireless Network Adapter driver

  sunnystaines 14:51 04 Feb 2014

we had a sony laptop a while back lost the internet all avenues failed till i spoke with the helpline for the router who suggested look along the edge of the laptop for a smaller slider, we found it moved and internet was back.

you post brough back the memory of the occasion and wondered if you have similar, even sony never advised us on the slider.

  yorkshirecath 16:12 04 Feb 2014

No exclamation marks on any of the adapters and they say they are up to date when i say update.

Can't see any type of slider on the laptop either i'm afraid

  yorkshirecath 10:05 05 Feb 2014

Can anyone else help? Thanks

  Woolwell 10:08 05 Feb 2014

You've tried connecting to your modem by cable and by wifi and neither work. This could well indicate that it is the modem that is at fault. Do you have any other devices working ok through it?

Try switching off the modem waiting a while and switching it back on.

  alanrwood 11:27 05 Feb 2014

Woolwell is right. If both wired and Wireless access is not working then the next common thing up the line is the modem or router which could have gone faulty or just lost its synchronisation with the ISP. Switching it off for a few minutes usually allows it to re-sync. If it doesn't then the next port of call is to consider if your phone line has gone down. Can you still make phone calls, has the phone junction box Internet Filter gone faulty (a common occurrence, try replacing it, they only cost a couple of quid).

Have you been subject to any local storms, power cuts etc which may have corrupted the router settings ie ISP login and password.

  yorkshirecath 12:48 07 Feb 2014

We have another laptop that the internet is working perfectly on though?

  Jollyjohn 13:26 07 Feb 2014

Have a look at th F keys along the top of the keyboard. One will have a wireless mast type symbol. Press and hold the FN key + Wireless symbol. Message should pop up wireless OFF. Do it again to confirm wireless is on.

Start Internet explorer. Go to TOOLS, Advanced tab, look for the RESET box, OK - this will clear saved passwords as well. Close and restart IE.

If still not working go to Network connections - Right Click on the wireless connection select Properties - look for tcp/ip select properties and ensure Obtain ip address automatically is checked and obtain dns automatically is checked.

If none of this works, try a different Ethernet cable and see if you get a connection.

  yorkshirecath 13:40 07 Feb 2014

Hi The Sony Vaio doesn't have a wifi key in the function keys, it's turned on and off by an app and is set to on. IE won't start up as there is no internet connection.

I have checked the Network connections and they are both IP and DNS are checked. The ethernet cable works perfectly and shows up as being connected when is plugged in but still no internet.

  rdave13 13:45 07 Feb 2014

Last resort, tcpip-stack repair.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

Halloween Photoshop & Illustrator tutorials: 20 step-by-step guides to creating spook-tacular…

iPhone X news: Release date, price, new features & specs

Comment créer, modifier et réinitialiser un compte Apple ?