No Internet Connection W98 Laptop to Wireless ADS

  Stylo 15:28 17 Oct 2006
Locked

Hope someone can help. I have set up a Belkin Pre N ADSL Router successfully between my desktop (XP Home) and laptop (XP Pro). No problems - can access the internet and share files through either machine (once I had sorted out Norton and drive mapping!).

Now I have connected my daughters laptop (W 98 SE) through a Belkin wireless USB dongle. The Laptop is connected to the network with a correct IP address can be seen from the router and the desktop - including file sharing. But I can neither access the internet nor see the other network computers from the Windows 98 laptop. I Have run the Norton home network wizard on the W98 laptop and it is in the same workgroup.

Any Ideas?

  Danoh 18:35 17 Oct 2006

If you use MAC address control, have not added the W98 laptop?

  Danoh 18:36 17 Oct 2006

May be worth trying to refresh the IP address on the W98 laptop; ipconfig /release, /renew

  Stylo 21:18 17 Oct 2006

Thanks Both

MAC filtering was not enabled, though on a nothing ventured basis I tried enabling it and added the laptop. No success.

I also refreshed the IP address - again no effect.

For info I can ping my desktop from the laptop and visa versa.

I have also tried disabling Norton on both machines and the firewall on the router same result - though after a few minutes I lost control of the router, it told me it was under control from another IP address - worrying, it promptly got turned off and the firewall re-enabled!

I think it may be the Belkin helpline.

  Stylo 22:31 17 Oct 2006

Just one more piece of info. If i connect by cable to the router I still cannot see the network from the W98 laptop but I can connect to the internet.

  Danoh 23:33 17 Oct 2006

"after a few minutes I lost control of the router, it told me it was under control from another IP address -"

I presume you have changed the default password for the Belkin router to one of your own choosing, preferably one made up of upper and lower case letters, numbers as well as special characters like # ~ etc.
Cause if you had not, the SSID is still the default "Belkin", and no security is setup on your wireless transmission,
anyone can login to your router and set themselves up for access!!

From what you say, someone has been doing just that.
So as a matter of urgency, you ought to connect by cable to your router and set it up properly by changing the defaults;
SSID
Router login password
Set MAC address control for just your equipment
Set Data Encryption (preferably WPA2-AES), again using as long a passphrase as possible, using combinations of special characters, numbers, upper and lower case letters.

  Stylo 10:23 19 Oct 2006

Hello Danoh

You presume correctly. More worryingly data encryption was set and the SSID had arleady been changed. All I did was switch off the firewall temporarly in order to see if that was contributing to the problem. However all relevant passwords and keys were changed immediately.Thanks for the concern and advice though.

I guess it could have been some sort of lockup or conflict caused by the W98 laptop struggling to connect as the offending IP address was that allocated to that machine a few minutes earlier, though the machine was shut down at the time of the problem. However better safe than sorry.

Back to the core question however, any other thoughts on the internet connection issue? I confess I am completely stumped - probably something obvious but it beats me.

Computers - !*$$??*!

  Danoh 20:01 22 Oct 2006

Sorry ~ I have zero W98 networking experience! But I am surprised that ipconfig/release and ipconfig/renew did not resolve any LAN IP address conflict?

  mgmcc 09:20 23 Oct 2006

Networking Windows 98SE is no different from any other operating system, Windows or otherwise. You connect by ethernet (wired or wireless), get an IP address by DHCP and, firewalls permitting, should have network and internet access.

However, in you original post you did say "I Have run the Norton home network wizard on the W98 laptop and it is in the same workgroup." I don't know what Norton software you have installed or what the Norton wizard you used is or does, but that rings alarm bells. If you've got something wrongly configured in there, it could have messed things up.

  Stylo 20:19 23 Oct 2006

Thanks for the input

The story has moved on since my last post. Firstly the Norton Wizard was the networking wizard under Norton Personal Firewall. In fact I subsequently simply set a range of permitted IP addresses in line with those issued by the router.

Secondly I blew the dust off an old W98 desktop I had in the loft. Inststalled the wireless adaptor, ran the Windows network wizard and mapped the hard drive. The computer is quite happy on the system, two way file sharing and internet.

Conclusion the problem is the W98 laptop and the Belkin wireless USB adaptor. To confirm this I connected the W98 laptop by cable to the router and 2 way file sharing and internet.

Now the only issue is printer sharing which I can do easily from a WXP laptop but not from either W98 machine. I have tried adding W98 drivers to the host (XP Home) machine and installed the printer on each W98 machine. Neither machine can see the printer when using the add printer wizard or when opening the host machine from the network.

I am now out of the country on business for the next 4-5 weeks so I guess it will have until I return.

In the meantime any thoughts are welcome.

Thanks again

  Stylo 15:22 21 Dec 2006

In case anyone comes back to this thread. The problem was eventually solved when my internet connection on the XP computer died. It tirned out to be a faulty nework card on the motherboard. Replacing with a PCI card then all the networking issues with the W98 computers were resolved. I can now file share and print from any of them.

As a postscript anyone trying to print through an XP machine from a W98 machine may find it easier to load the 98 drivers onto the XP machine (at least for Epson) then import the drivers over the network when using Add Printer on the W98 computers. I know it worked for me better than trying to load the drivers on the XP machines from a disk.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best phone camera 2017

Stunning new film posters by Hattie Stewart, Joe Cruz & more

iPad Pro 10.5in (2017) review

28 astuces pour profiter au mieux de votre iPhone