No internet with a Belkin USB adapter

  Maxieuk 14:32 04 Apr 2008

I have just reformatted my hard drive on my laptop and now I can’t get it to recognise my network on my desktop computer.
I have a Belkin router wired to my desktop and I am using a Belkin Wireless G USB Network adapter on the laptop.
Before I formatted the laptop it was on the network and could connect to the internet.
I have reinstalled the USB adapter and it connects to the router, but not to the internet. I have run the network Assistant on the laptop several times, just as I did the first time, but it is unable to see the desktop and the desktop can not see the laptop. I have checked that the password is correct. I am not too bothered that the computers can’t see each other, but I need to connect the laptop to the internet.
Any help will be greatly appreciated as I don’t have much hair left to pull out.

  Fruit Bat /\0/\ 14:34 04 Apr 2008

Firewall set to allow your browser?

  woodchip 14:37 04 Apr 2008

You have to put Encryption key in from Router, if it's wireless. Also have you loaded drivers for the adapter

  Maxieuk 17:37 04 Apr 2008

I have tried turning off the firewall, but it made no difference.
I have the router set for 128 bit WEP Encryption and have entered the pass phrase into the laptop and when I open the Belkin connection it shows that it is connected to the router but not to the internet. There is a cross between the two.
Do you think it is worth trying to set the router without encryption?
Kindest regards,

  Ditch999 17:55 04 Apr 2008

It sounds like the Belkin modem/router is denying the laptop access to the internet. Did you change any settings in it from the default ones or do you have to run a Belkin setup disc on the laptop?

  woodchip 17:55 04 Apr 2008

Try turning the router off for a bit then turn it back on and try it.

You would do a lot better to set it to WPA

  Maxieuk 18:48 04 Apr 2008

I have tried resetting the router through the Belkin website and I have tried turning off the router, waiting for 10 minutes and then on again, but to ne avail.
The settings that I made when I installed the router have not been changed and the laptop used to connect with no problems. My grandson has a laptop that still connects to the network and the internet.
I am tempted to try disabling the security mode, but I'm not sure if that will just cause more problems.
I am very sorry, but as an old man I am not very computer competent, but I am learning all the time.
Kindest regards,

  Ditch999 18:53 04 Apr 2008

Have you tried running the setup wizard in Internet Explorer? It is accessed from Tools>Internet Options>Connections tab then click on the Setup button.

  Woolwell 23:26 04 Apr 2008

I am not sure that you are actually connected to the router. I use a Belkin USB adaptor in the office and it will show that it is connected to the router with a cross for the internet but a ping to the router does not work.

Sorry to ask this but are you sure that you have the password totally correct?

  Maxieuk 09:44 05 Apr 2008

I have run the Network wizard on the desktop and then used a USB stick to make the setup for the laptop. When I try to run the wizard on the laptop it tells me that it is unable to run. So I have to run the wizard through ‘My Network’ on the laptop, but I was given the opportunity to print out the settings from the USB stick. That gave me the correct pass phrase to use. I have also run the setup from Internet Explorer, but I keep getting the same result.
When I click on the little green TV near the clock it opens up the Belkin connection and there is a stream of 0’s and 1’s going between the laptop and the router, but there is a X between the router and the Internet.

  Woolwell 11:16 05 Apr 2008

I haven't got the Belkin set up in front of me so I am working from memory.

Double click on the "little green TV" and on the first page you will have the X. You can click on more and you should see IP addresses allocated. However there are probably other tabs too and one of them will allow you to view available wireless connections, another to set up the profile and another to connect. Trying using the set up profile again (if necessary duplicating) and then connecting using the new profile.

To check that you are actually connected to the router, which I still doubt despite the Belkin software stating that it is, click on Start - Run - and in the box type CMD then ok and in the new box type ping and this will tell you if the laptop can actually see the router.

Alternatively from the desktop open the Belkin router and look to see if your laptop has been assigned an IP address.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

The Evil Within 2 review-in-progress

Photoshop CC 2018 released with new Curvature Pen and better brush tools

Camera tips to take better iPhone photos

Les meilleures applications de covoiturage 2017