No Connectivity on Network

  slydog 15:38 11 Mar 2006
Locked

Me again Im having a sorting out problems day! I dont seem to be able to set my small home network any more .It worked fine for ages and then stopped connecting and gives me teh follwing error messegae when I use the winXP wizard to set up the connections (on Both PC's) Ltd or No conectivity. network did not assign a network address. I have tried changing both network cards and PCI slots, One of my PCs shows packets sent and recieved and other only packets sent, so I am assuming it is this one which is giving me the problems. But everything else seems to be working OK.
I have checked the network card configuration of both PC's and neither have been assigned a network address. But the one that is recieving packets shows values for Early Tx Threshold, Link Down/Power saving and Link speed/Duplex mode which does not appear on the other.
Can anybody help.

Many thanks
Slydog

  mgmcc 16:35 11 Mar 2006

What are the two network cards connecting to - directly via a "crossover" cable or a Network Hub/Switch/Router?

If directly, unless you are either running "Internet Connection Sharing" in one of the PCs or have manually allocated IP addresses, there is no way for the adapters to get an IP address. Windows will allocate an APIPA address (Automatic Private IP Addressing) in the 169.254.x.x range, you will get the "Limited or No Connectivity" indication and the PCs *may* be unable to communicate.

  slydog 19:18 11 Mar 2006

Hi mgmcc
Yep PC's are connected via a direct crossover cable.
And i have chacked internet connection sharing setting and neither seem to be running this. So how do I solve this, run internet connetion sharing for the setup? I didnt have to do this first time I set up the network.

  slydog 21:23 11 Mar 2006

Can any body help on this?

  mgmcc 10:26 12 Mar 2006

Open the Network Connections folder, right click the Local Area Connection and select Properties. Highlight "Internet Protocol (TCP/IP)" and click the Properties button. In the box that opens, click "Use the following IP address" (or similar, I don't have a Windows PC running at the moment). Enter:

IP address - 192.168.0.1

Subnet Mask - 255.255.255.0

and then in the second PC do the same and enter the IP address 192.168.0.2 with the *SAME* Subnet Mask of 255.255.255.0

As there is no internet involved, you don't need to enter the Default Gateway or DNS Server addresses.

Any firewall software needs to be configured to allow access to the networked computers.

  slydog 13:06 12 Mar 2006

Many thanks for the reply mgmcc and your suggestions have worked after a fashion as I now have an established connection. However the PC's still arent communicating. I have turned off both window firewall and the zonealarm I run on both PC's with no effect- except when I tried to turn off win firewall it reported unble to do so because of WMI failure so I ran a scan via the help facility and this also reported WMI failed. Then opened up WMI and this reports failed to connect as 'interface class not registered'. Now I'm stuck dont knw where to go from here. have you any idea's
Many Thanks
Slydog

  slydog 14:39 12 Mar 2006

Update - the WMI failed error is only on one of PC's (the one Im using now)The other one can 'see' this computer but cannot logon to it message says this computer is inaccessible. This PC however cannot 'see' the other at all and it's presence is not shown when I open view network computers.

  slydog 15:32 12 Mar 2006

Not having much luck here can anybody help I'm thinking maybe a clean reinstall of Windows/
Cheers
Slydog

  mgmcc 20:48 12 Mar 2006

<<< WMI and this reports failed to connect as 'interface class not registered' >>>

Have a look at the instructions click here and see if that fixes it.

  slydog 21:05 14 Mar 2006

Thanks for the advise mgmcc after a couple of hours fergalling Ive finally solved the problem. The work around you suggested didnt work but it put me on the right lines as it looked like a corrupted repository was likely to be the problem I checked the MS knowledge base and came up with this command which when used with SP2 deletes, rebuilds and upgrades the repository: for future ref the command is: 'rundll32 wbemupgd'
and can be found here: click here
(couldnt figure out how to insert a link).
Just one problem left now only one of the PC has acces to hte other although both windows and zonealarm firewalls are turned off and file shareing is enebled. One of teh the PC's reports access denied are there any other settings I am missing.

  woodchip 21:23 14 Mar 2006

Have you set what you want to share? In Windows Explorer or My computer right click drives or folders share set for share

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment regarder des séries et talk-shows américains en France ?